Salta al contenuto principale

The Canon AE-1 is a 35 mm single-lens reflex (SLR) film camera for use with interchangeable lenses.

30 Domande Visualizza tutte

The camera keeps draining my batteries.

I put in a fresh 6V battery into my camera a week ago and now the shutter won't fire. I know the battery is drained because the needle is above the index (5.6 mark in viewfinder) instead of below. Is this an issue with the capacitor or corroded terminals? I bought it locally and the guy said it was his Dad's camera.

Thanks

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 2
Aggiungi un commento

3 Risposte

Risposta Più Utile

The battery chamber contacts & wires often corrode up. Did you see any corrosion within the battery chamber? The pins are clean and are not discolored? Getting to the chamber wires requires a fair amount of disassembly.

Review this service manual to locate the MG3 on the bottom of the camera so you can measure the battery power Canon-AE-1 Service Manual.

Questa risposta è stata utile?

Punteggio 1

Commenti:

Thanks for answering. The most I have done to address this issue is cleaning the contacts with baking soda and vinegar. It's still too early to tell if this has fixed the issue yet as the new battery I am currently using is still powering the camera.

I have not checked the MG3 yet and I plan on doing that next.

da

Try using a Pen eraser (Grey) as its more abrasive than the Pencil (Pink) to make sure the oxides are removed.

If that still fails you'll need to replace the battery chamber.This is a big job!

da

don't answer if you don't know. It doesn't make sense. The battery doesn't discharge because of corroded or interrupted contacts! If that was the problem, it wouldn't have worked in the beginning.

da

@Paul Pacurar - You're thinking in the right direction if the pathway though the circuit was the issue!

Here corrosion can also be between the contact on the back side of the battery chamber and the metal body. The insulator is not very large and is a common issue in the AE-1 camera.

da

Aggiungi un commento

corroded terminals might cause a symptom of a dead battery because of a high resistance connection. Best test the batteries outside the camera.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I also don't know for sure the answer, but at least I have a more logical supposition. The camera has coil under the bottom plate that is basically an electromagnet to control shutter speeds. It has a very thin wire that lets power flow to it. However, that wire has only a thin insulation and it might short circuit at some point. If that is the case, is not complicated to fix, but it requires precision. A workaround would be to only let battery while shooting. 5 mins, or even 10 maybe won't drain the battery; at least it makes the camera usable

Questa risposta è stata utile?

Punteggio -1
Aggiungi un commento

Aggiungi la tua risposta

John Freecss sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 5

Ultimi 7 Giorni: 24

Ultimi 30 Giorni: 100

Tutti i Tempi: 1,898