Salta al contenuto principale

The first generation RAV4, known as the XA10 series was constructed on a unique platform that shared Carina and Corolla elements. It launched in Japan in May 1994.

6 Domande Visualizza tutte

Starts but runs rough!

I have a 1999 Toyota Rav4 2.0L and I've replaced coils, plugs, timing belt, crank sensor and cam sensor, did continuity test from crank sensor and cam sensor to the computer and the wiring checks out ok, but its still throws a p0340 code for cam sensor, any ideas would be greatly appreciated

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

Commenti:

Yes, checked all wiring and did continuity test from crank and cam sensor connector to ecm connector and checks out ok, thinking it may be the ecm but wanted a second opinion I guess

da

Aggiungi un commento

2 Risposte

Risposta Più Utile

Engine vacuum leak will cause it to run rough and can throw ecm / cam sensor code

Questa risposta è stata utile?

Punteggio 2
Aggiungi un commento

checked wires? follow the harness back, look for breaks or rubbing.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Maybe bad one out the box?

da

I took it back off, did ohm reading and passed a piece of metal in front of it and its putting out correct voltage!

da

Aggiungi un commento

Aggiungi la tua risposta

crogers_2882 sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 2

Ultimi 7 Giorni: 4

Ultimi 30 Giorni: 17

Tutti i Tempi: 152