Salta al contenuto principale

Repair information and guides for the updated version of the 2015 Retina MacBook that was released in early 2016. Model A1534 / EMC 2991

139 Domande Visualizza tutte

MacBook A1534 function keys failure after keyboard replacement

Retina Macbook 12" A1534 (2016)

My problem is very strange! After keyboard / trackpad / ribbons replacement, F1 to F12 keys are clearly working, But! The special features like brightness and volume adjustment are not working.

Tried a few methods:

  1. Reset SMC
  2. Reset PRAM
  3. Checked & unchecked System Preferences/Keyboard/Use F1, F2 as standard function keys
  4. Checked & unchecked System Preferences/Accessibility options

Still no clue!

Checked the keyboard online and every keys are functioning.

Currently using Keyboard Maestro to temporarily fix the problem, but I would like to know the reason behind the problem.

Thank you.

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
2 Commenti

Where in the world did you get a keyboard?


I've got it from China.


Aggiungi un commento

3 Risposte

Soluzione Prescelta

Could be a faulty keyboard (holding down fn by itself for example). Other than that, I am not too sure. Have you tried it with the old keyboard (assuming the function keys were working)?

Haven't replaced many keyboards on these since the UK layout was not available for long before there was a shortage of these, but have never come across this issue before on this model or any model.

Questa risposta è stata utile?

Punteggio 4

13 Commenti:

Thanks a lot for answering! Have tried with the fn key, it works perfectly to call up the dictation with two strikes, so I assume that it is ok~


Possibly a software issue in that case, have you tried booting into an external drive or reinstalling the OS?


@reecee - Do you have a MacBook 2015 as well as a 2016 system to compare the keyboard Alan has?


I only have one in at the moment for a screen replacement, not sure the year though it's at the shop


@Reece I have tried reinstall with different versions, still no clue.


Mostra altri 8 commenti

Aggiungi un commento

Each keyboard has an ID string so the system knows what it is. I'm wondering if the new keyboard is from the older 2015 model.

Also which keyboard did you get a US standard or one of the foreign language ones?

In either case go into About this Mac > System Report, then open the Hardware tab and jump down to USB. On the right panel open the twistys under USB 2.0 Bus > Hub and click on the Apple Internal Keyboard / Trackpad. Now copy off the lower pane's info and paste it here.

I don't have access to your exact model hopefully someone else does so we can get a comparison to see whats different.

Questa risposta è stata utile?

Punteggio 1

1 Commento:

Thank you very much for your kind support! Here is Te information:

Product ID: 0x0272

Vendor ID: 0x05ac

Version: 6.22

Manufacturer: Apple Inc.

Location ID: 0x01000000


Aggiungi un commento

Hi Alan,

You will need to re-map the keyboard to the motherboard - Apple Repair Centres have a tool which can re-map the Keyboard which will allow the function keys to work. Without the mapper being run on the device the F keys will simply be F keys.

Kind Regards


Questa risposta è stata utile?

Punteggio 0

1 Commento:

There is no special app tool. Are you thinking about this: Technical Note TN2450: Remapping Keys in macOS 10.12 Sierra

Sadly, that won't work here as the internal USB keyboard driver is intended to work with a different keyboard than what Alan had installed.


Aggiungi un commento

Aggiungi la tua risposta

Alan Wong sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 3

Ultimi 30 Giorni: 13

Tutti i Tempi: 3,279