Salta al contenuto principale

Device and repair information for the Behringer Eurolive B212D speaker system.

30 Domande Visualizza tutte

Why is my speaker have flashing lights and no sound?

No sound and lights flashing?

Update (03/12/2016)

I dont know I am having the same problem

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 4
5 Commenti

Hi, Which light is flashing, the power light, the clip light or both?

da

Both green lights for wireless mic and power light on channel 2 and clip light on channel 1. And it's not putting out any sound.

da

i have turbo sound powered speaker and it has no sound when i connect my device to the input as well as in mic input but when i plug it in the out,thru it has working in the other speaker and i got flash and signal from my mp3 device..thanks for the answer.

da

I have the same problem with the Behringer Europort PPA500

Flashing lights on the front and no power or volume etc…

I have no idea what to change?

people are saying the IC?

can someone clarify?

da

Old thread - sorry to resurrect. B112D with the same symptoms as everyone else….all lights flash on, then Mic 1 (wireless) stays lit while Mic 2 (wireless) flashes dimly. Actually got it free from someone who said they’d sent it to Behringer for repair and it still didn’t work.


Board Info

P0AEB

PCB210011REVB_01


Seems that it has 47uF and 25v caps, rather than the 35v as mentioned above. I need to see if I have any spares laying around. On this board they’re C2 and C3. There’s also a third at C158. I found a few images of a circuit diagram, but they’re not full res…so reading them wasn’t going so well.


C2 - measured 562Ohm

C3 - measured 1350Ohm


Don’t think my meter can measure capacitance - never needed to before, but meh. I’ll be replacing these caps and will report back.

da

Aggiungi un commento

2 Risposte

Soluzione Prescelta

Hi,

Bit confused here. You're stating a wireless microphone. Have you got some sort of wireless equipment connected to either the Behringer Eurolive B212D XLR input or the 3.5mm TRS input connection? If not how is your wireless microphone's output being connected to the input(s) of the speaker?

According to what I can find out the Behringer Eurolive B212D does not have wireless capability.

If you do have some sort of wireless microphone interface equipment connected then I'm assuming that you have got it setup somehow as per the image below. If not and your wireless microphone is 'connected' to another piece of equipment for it to work, check its' connection to the speaker(s) and ensure that it is connected to the appropriate input and setup as per below depending on input connected.

If the microphone? is connected to the XLR input (as shown in the image) set the level adjustment on both the speakers half way between the centre (vertical) position and the maximum position. (turn the selector clockwise).

If the microphone? is connected to the 3.5mm TRS input socket set the level adjustment on both the speakers half way between the centre (vertical) position and the maximum position. (turn the selector anti-clockwise)

By speaking into the microphone, adjust the level adjustment on both of the speakers to get the desired volume. (Also check the output level of the wireless equipment?- if any- to see that it is not set too high). If the clip light comes on (on either speaker) it is too loud and needs to be scaled back until the light goes out. Also adjust the equalizer controls on both speakers to get the desired 'sound'(bass and treble mix).

Block Image

Questa risposta è stata utile?

Punteggio 3
Aggiungi un commento

RE: Teixeira

When you run an amp into clipping, quite often bad things happen. The initial thump is probably because the protection circuit has not completely engaged yet or is somewhat defective. Basically the amp section now needs some work. I would expect to find that the output transistors are shorted. I believe that this unit uses discrete transistors for outputs. This should be a fairly simple repair for an experienced amp repair individual.

Dan

Questa risposta è stata utile?

Punteggio 1

17 Commenti:

Hello, on a Behringer EPS500MP3, I have looked into the capacitors and they are fine. Could it be just the IC ? It has same symptoms, POWER LED and LIMITER flashing. You can also ear a "tic tac" noise on the board

da

Hey i got exactly this problem, what to do???

da

I had the same issue with one of my Behringer B115W's. I tried twice to get it repaired under warranty ... Behringer ignored both of my on-line requests.

Because I have two gigs coming up, I decided to fix it myself. I was expecting a "bad Capacitor" issue on the power entry side ... (i.e. symptoms dim pulsing LED's and no sound)....

to my surprise ... all caps looked good.

So I re-seated all connectors and put it all back together and it's started working fine again.

da

i have the same problem mike with the same speakers can you please describe to me what it was that you did thanks djloud704@gmail.com

da

change the capacitor c2 and c7. mention at board. you can see at mosfet area.

da

Mostra altri 12 commenti

Aggiungi un commento

Aggiungi la tua risposta

Cody sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 5

Ultimi 7 Giorni: 61

Ultimi 30 Giorni: 257

Tutti i Tempi: 30,060