Salta al contenuto principale

Numero modello A1707. Rilasciato a giugno 2017, questo MacBook Pro adotta processori Kaby Lake fino a Intel Core i7 quad core da 2,8 GHz con Turbo boost fino a 3,8 GHz.

321 Domande Visualizza tutte

Replaced battery, now left side fan is running at 7,000rpm constant.

Hello forums folk,

I've seen this issue somewhat addressed on here a few times. If I had seen a fix I would not be writing this!

So a few days ago I performed a battery replacement - I followed the guide on this site to a T, and took my sweet time. Upon start up I noticed the left side fan whir to a pretty aggressive start. I have reset the SMC, and NVRAM numerous times to no avail. I just received a replacement fan (from ifixit as well) and just installed it only to have the same issue. My mac fan speed at shows roughly 7,000rpms at all times on the left fan and it will not take to any custom speed input.

At a loss here guys and gals, initially did this to save time and money - can't really afford to give my only computer to Apple for 2-3 weeks, but now here I am and its seeming like I don't have much of a choice.

Any thoughts, tips, tricks, are more than welcome - thank you!

EDIT* diagnostic check shows

"there may be an issue with the fan. Reference Code: PPF004. Additional reference code PPF003"

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
Aggiungi un commento

2 Risposte

Hey Dillon!
Sorry you got this problem, doesn't seem fun at all to hear all day. Do you happen to know if by any chance you accidentally touched or messed around with any setting or anything on board? (like a fan controller)

Questa risposta è stata utile?

Punteggio 0

1 Commento:

hey!

thanks for your response, I did not (knowingly) touch or mess around with any setting or anything on board. simply removed the logic board, removed the old battery, and reassembled.

da

Aggiungi un commento

I'm suspecting you might have not fully seated the ribbon cable, connector latch not closed or damaged the connector or load resistor

Block Image

Questa risposta è stata utile?

Punteggio 0

2 Commenti:

this is for the fan correct?

I'm not sure how that would have happened when I only replaced the battery to begin with, which is what initially brought this issue to light. this issue did not exist before changing the battery, and still exists now after replacing the fan. the fans ribbon cable was not touched when I replaced the battery. at least not knowingly.

do you recommend opening back up to view if the load resistor is missing?

da

@dukegonzo - Yes this is the fans connection to the logic board as the keyboard cable carries the signal to the logic board (Apples efforts to reduce the parts count)

I see no way to solve your issue without at least inspecting things. Take a picture so we can see things too posting it here Aggiungere immagini ad una domanda

da

Aggiungi un commento

Aggiungi la tua risposta

Dillon Smith sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 4

Ultimi 30 Giorni: 8

Tutti i Tempi: 114