Salta al contenuto principale

Guides and repair information for televisions from Hitachi, a Japanese electronics manufacturer.

28 Domande Visualizza tutte

TV has black screen but has sound. Works after months unplugged

Hitachi TV, can hear sound from it.

  • Have tried unplugging from wall and leaving for an hour.
  • Tried plugging directly into wall
  • Tried holding down power button for 30 seconds then plugging everything back in
  • Red light blinks when plugged in, but when you try and turn it on light disappears and no screen change
  • Shone light against screen to see if a back-light issue (it's not)
  • Tried unplugging the HDMI cables that were in and using different ones

Honestly we gave up and left it for a couple months. On a whim we plugged it back in and… It worked??? Was good for a couple weeks but today tried to turn it on and it's dead again.

The fact it came back to life after months is baffling to me. Any ideas what would cause this?

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

4 Commenti:

How old is this TV? Can you post pictures of the boards in the TV? Aggiungere immagini ad una domanda

da

It's nearly 3 years old. But still very confused what component could fail and months later work again

da

@emma.brady12 Can you upload pictures of the boards?

da

emma.brady12 what exact model is your Hitachi TV? Wile your TV has sound and no picture, in a darkened room shine a flashlight beam at an angle against the screen. See if you can make out shapes or silhouettes. This will not work on Plasma TV's etc. so we need to know the model for sure.

da

Aggiungi un commento

2 Risposte

Unplug the HDMI from one input and plug it to a different input to test if a port is bad. Replace the HDMI cable as it may have a short or another defect which causes the black screen issue. Unplug the TV for 5 minutes to attempt a reset. Unplugging the TV will reset the television and clear any temporary issues.

Questa risposta è stata utile?

Punteggio 0

3 Commenti:

As mentioned above, have tried unplugging it for many minutes (hours even) and it makes no difference. Have also tried each HDMI port using different cables for each, and also having none plugged in at all. I don't even see the hitachi logo pop up on the screen which it usually does when booting.

da

That's weird. How old is your TV?

da

I have this problem. Unplug all the leads in the back of the TV as well as unplugging it. Leave for twenty minutes. Plug all leads back in. Then should work. No idea why this happens but mine keeps doing the same if I don't use it daily. Went away for the weekend and it dud it again! Working now.

da

Aggiungi un commento

emma.brady12 what exact model is your Hitachi TV? While your TV has sound and no picture, in a darkened room shine a flashlight beam at an angle against the screen. See if you can make out shapes or silhouettes. If you can, you know that it is the backlight that has failed. Since it generates an image, that would be excluding the main board and most likely is a failed backlight array. If there are no images etc. It is possible that this is the T-con board, or the man board not telling the power board to turn the backlight on. Board failures are usually registered by the TV's firmware and would generate a power LED blink code error. This will not work on Plasma TV's etc. so we will need to know the model number.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

emma.brady12 sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 8

Ultimi 7 Giorni: 24

Ultimi 30 Giorni: 115

Tutti i Tempi: 3,201