Salta al contenuto principale

The Shark Rotator NV502 vacuum was made in 2013, weighs 15.5 pounds, and includes a lift away handle. The vacuum can be used on both carpet and hardwood floors.

17 Domande Visualizza tutte

Why won’t my vacuum turn on?

I've pushed the 'ON' button on the vacuum , but it wont turn on. What can i do?

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 6
11 Commenti

Yesterday mine just stopped. The light is working, it's not clogged up. Nothing happens at all till I drop the handle and then the brush roller spins but that's it. No suction or anything. Put the handle back in the upright position and everything stops. ????? Help.

da

Exactly what is happening to mine!!

da

Same = see my answer below

da

Mine just started doing the same. How do you fix it?

da

Mine too grrrr

da

Mostra altri 6 commenti

Aggiungi un commento

14 Risposte

Soluzione Prescelta

First, make sure the vacuum is plugged in. If the vacuum is plugged in and the switch is pushed on, but it's not turning on then try to reset your circuit breaker or reset the motor thermostat. The steps to reset the motor thermostat can be found in the troubleshooting guide.

Questa risposta è stata utile?

Punteggio 4

3 Commenti:

This is not the question asked. The brushbar turns (so the power is on) and there is no suction.

da

mine was doing the same thing, the power to the brush would turn on but the actual motor was not. The switch was not operating fully. I took mine completely apart, cleaned the switch and now it works perfectly. It took about an hour and most of that was locating the screws. Also, you will need 2 different size torque bits in order to do that! Hope this helps.

da

Just put together a brand new Shark navigator. Will not turn on. Totally dead. Great product.

da

Aggiungi un commento
Risposta Più Utile

The collection canister has a switch that engages when it locks in that can wear and not function, try removing the waste canister/collection canister and insert it carefully to attempt to engage the switch

Questa risposta è stata utile?

Punteggio 9

8 Commenti:

Thank you so much! It was that simple.

da

Perhaps the newer models have this switch, but mine doesn't. I'm thinking mine is either fried, or the cord is worn in the vacuums interior.

da

The canister removal and replacement did it. Thanks!

da

6/23/19- This works! I can’t believe it was this simple, stupid. I went through every hose and removed all the strings on the brushes. Been playing with it for 30 minutes until I found this “ifixit” web site!

da

Thank you! That was simple..

da

Mostra altri 3 commenti

Aggiungi un commento

This just happened to me and the issue is the power switch. If I short the switch leads with a screwdriver (after disassembly), the vacuum runs. Now where can I get a new switch...

Questa risposta è stata utile?

Punteggio 2

5 Commenti:

Gloria it was very simple thanks Joey. What a relief!!!!

da

Same problem for me. It only turns on when brush is engaged and handle down. I've cleaned the brush and filters. Brush turns on but the power doesn't come on until I pull the handle down as if to start vacuuming. But no suction. Can anyone help?

da

Hi Carrie, did you get a solution to your problem? I have the same prob.

da

I have the same problem Carrie

da

Same problem as Carrie.

da

Aggiungi un commento

Same thing just happened to me, there is power because when I lower handle for brush roll, it works but no suction and when handle is up then nothing, no noise or suction. Crazy, me red and white on worked for years and I have had this less than a year, going to try to use warranty. This model is the purplish one, professional with attatchments, not the slim one or anything, just a better version of my red and white professional one.

Questa risposta è stata utile?

Punteggio 2

3 Commenti:

Hey I have this exact problem now. Did you get yours figured out Christina?

da

Any answer? Mine is the same. No power til lowered and no suction, but brush works.

da

Lisa, Carrie or Christina? Have any of you found a solution? I'm having the same issue.

da

Aggiungi un commento

Thermal Protection Switch. (For mine)

Clear any obstruction - I found a clog in both sides of the removable elbow below the wand.

Let it cool off for a 15 -30 minutes with the cord unplugged. Some thermal switches will not reset as long as it’s plugged in.

Reassemble if needed, plug it back in, turn it on, and clean.

Questa risposta è stata utile?

Punteggio 2
Aggiungi un commento

It's likely the thermal overload which is that 1/4" back thing with two legs coming out and a short one in the middle.

Solder a link from the middle of it to the black wire and you will bypass it.

Keep the vacuum clear and you should have no problems.

You will have no thermal overload for the motor so the next time it may burn the motor but it beats throwing it out

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

In our case, the vacuum just stopped working right in the middle of use. My wife was using it when it happened. When I came home we both looked at it and concluded the roller and lights worked when they were supposed to, bu the vacuum motor itself was not running. Reading this wiki , the motor thermostat seemed like the right answer, but it had been down for well over an hour and should have cooled down by then.

We then UNPLUGGED the machine (it had been plugged in the entire time). Went to dinner, came back, and it worked just fine. Going to clean the filters so it doesnt have to work so hard.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

Do the vacuum have to set for awhile until it's cool off

Questa risposta è stata utile?

Punteggio 0

2 Commenti:

So what too do

da

hi, mine did same thing and when I checked the front filter I noticed it was hot. Was yours hot, did you get it fixed?

da

Aggiungi un commento

Nothing happens at all when I switch ours on. No light no noise no nothing. Any ideas?

Questa risposta è stata utile?

Punteggio 0

3 Commenti:

Same with mine. I was literally just using it and it was working fine, and no nothing.

da

Just bought the cordless shark duo clean today put it on to charge the charging lights came on fine and is now fully charged but when I turn it on it is completely dead the only power it has working are the charge lights????

da

I’m having the same issue, were you able to get your resolved.

da

Aggiungi un commento

I have the Shark Apex Vacuum. I got it for Christmas. I was just using it to suck up dirt on the floor. Went to turn it back on but the rollers won’t roll. The light on the vacuum comes on and then the light starts to blink. Help!!!!

Questa risposta è stata utile?

Punteggio 0

3 Commenti:

Hope to hear back with an answer soon.

da

Reset the unit by turning it completely off and wait for 2-3 minutes before turning it on again. This will reset the vacuum cleaner’s system and fixes the errors or bugs inside.

da

I have the same problem with shark rocket vacuum. Suction motor works. The roller does not work. There is light on the board. I removed the roller cover and directed the power supply. Now the brush roller and the motor works. I can’t figure out when I attach the suction motor, roller won’t work but there is light on the board.

da

Aggiungi un commento

We cleaned the filters as it said on the label by the filter and now it works like new.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I have the shark duo clean. Lights work but no motor. I was vacuuming and the motor stopped. It's only 6 months old. I unplugged it for 30 minutes, cleaned the filter, and mad sure there's no clogs. Motor still not working. Only the lights.

Questa risposta è stata utile?

Punteggio 0

2 Commenti:

I have the shark duo clean as well. Switched it on and it suddenly went off

da

Pat Voeks mine is doing the same thing. What did you end up doing?

da

Aggiungi un commento

Hey everyone.. thanks so much for this forum. I didn’t see any answers to mine, so here it goes. My motor turns on, suction works, but no light at all to the indicator light on top of the roller part. I have cleaned all parts, made sure there are no obstructions, made sure all parts are clicked in together and no dirt in the plugs. Still no light on indicator… help please ??????

Questa risposta è stata utile?

Punteggio 0

1 Commento:

Hi I have AZ950UK WHEN you push it it works when you pull it lights go off and green light can you help me thanks andy

da

Aggiungi un commento

I have the Shark Duo Clean. Vacuum wouldn’t turn back on when I switched rooms and outlets. Lights went on, roller was spinning and green “brush roll indicator” light was on. I unplugged, rinsed the filter and emptied the waste catcher. Plugged back in and it works perfectly.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Samuel sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 79

Ultimi 7 Giorni: 548

Ultimi 30 Giorni: 2,649

Tutti i Tempi: 226,390