Salta al contenuto principale

Repair information for the first generation Isuzu Trooper. Available as short or long wheelbase three or five-door wagons with 4-wheel drive and independent front suspension.

2 Domande Visualizza tutte

Wipers getting stuck + motor drawing power

Hi, I have a 1984 Isuzu Trooper 3dr. Lately I’ve noticed that sometimes the wipers would randomly turn on when I started up the car and simply stop in a random position. Then I can’t get the wipers back down unless I pull quite hard on both of them.

The motor is drawing power as well (car had a voltage gauge for some reason) and it’s honestly irritating. I’ve replaced the wiper motor 3 times already and since it’s the rainy season over here I really don’t to be stuck without wipers in heavy rain again.

Is there anything I can do other than replace the motor yet again?

(As if anyone here actually knows about these 1st gen Troopers…)

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
Aggiungi un commento

3 Risposte

Risposta Più Utile

@ngs765 could be wiper linkage problem. If the linkage binds it will require more work from the motor and like you said a motor replacement does not permanently fix this. Check the linkage by removing the cowling just below the wipers.

Questa risposta è stata utile?

Punteggio 1

1 Commento:

I had suspected that since the passenger side wiper sometimes is out of sync. I'll try to fix that.

da

Aggiungi un commento

Often times the headlights must be turned on for the wiper cycle to complete. It was a safety design protocol from the late 70’s.

just a guess however.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Tu problema es que se rrcecan los ejes donde van los brazos de los cepillos .desarma todo el varillaje lubrica los eles con poca grasa cambia los bujes plásticos que acopla el motor y el segundo brazo .vuelves a montar y tu problema estará resuelto .

Google translate:

Your problem is that the axes where the arms of the brushes go are damaged. Disassemble all the rods, lubricate the rods with little grease, change the plastic bushings that connect the motor and the second arm. Reassemble and your problem will be solved.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

amatsuda sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 6

Ultimi 30 Giorni: 15

Tutti i Tempi: 216