Salta al contenuto principale

Aggiusta la tua roba

Diritto alla Riparazione

Store

The April 2014 update of Apple's 13" MacBook Air features refreshed dual-core i5 and i7 processors, plus slightly increased battery performance.

252 Domande Visualizza tutte

Is flashing question mark folder death of SSD or logic board?

I am getting flashing question mark which means no OS found. But sometimes my system boots normally and works perfectly fine until I shut down and reboot only to find same error.

I ran diagnostic test and found error VDH002 which says an error with storage device.

I installed macOS on an external drive and booting from it seems perfectly fine. Before buying a new SSD for my Mac I thought to confirm if it is really the culprit or is the logic board. When I removed the top cover of my Mac I found some weird marks on the logic board and SSD (see pics). Is it normal or is it some moisture?

Block Image

Block Image

Block Image

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
Aggiungi un commento

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

3 Risposte

Risposta Più Utile

Your failure sounds like a damaged SSD socket connector.

When you pull the SSD out you need to make sure you don’t lift it as doing so will crack the connector case so the contacts are not pressing against the SSD contacts on the board.

Take a few pics from the sides of the socket with the SSD inserted, and post them here for us to see.

Questa risposta è stata utile?

Punteggio 1

Commenti:

I am not able to come to a conclusion as what actually happens is- my system shows a question mark folder, I leave it for sometime say overnight and next day I turn it on, it works perfectly fine. If I try rebooting I will get blinking question mark folder.

da

Did you take the pictures so I can show you the area of damage

da

Aggiungi un commento

What are the marks? All you are showing is the Wireless Card to M.2, I cant see any “weird marks on the logic board and SSD”

The symptoms that you are having are typical for an SSD that is not plugged in properly, its circuitry could be fulty or the SSD is on its way out, which is unusual as god and reputed brands of SSD’s last a long time and are very reliable! I use a Samsung 960EVO and they are lighting fast and very reliable and the Samsung 960PRO are even better and quicker.

I suggest that you check how your SSD is pugged in an that are no faults there, firstly, then, see how the cabling to the SSD is to the mainboard. Check all that first before replacing your SSD to a reputable and known brand, that is what I did and never ver had problems.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Weird marks as in the dark patches around the components of the board. I am not sure if this is normal or are signs of moisture.

da

The white dots on your logic board are called LSI (liquid submersion indicators), they turn red when exposed to liquids. Yours, at least the ones I can see, have not been activated.

da

Aggiungi un commento

I have the exact same issue with my machine (identical model). Family member took the MacBook in for third party repair due to the question mark issue during startup (steady, not blinking). This third party shop wasn’t able to fix the issue and ended up keeping (stealing) the original SSD after they gave the MacBook back. After disassembly and inspection, I found no issues besides the missing SSD. Ordered a new compatible SSD from OWC and installed using precautionary measures (anti-static mat and careful lifting/plugging of stick into SSD connector). Machine hadn’t previously run High Sierra and didn’t have updated firmware/EFI to support the SSD. Resolved that issue, installed High Sierra to SSD, and machine was working for a week before stability problems occurred. Further inspection and use of Apple Hardware Diagnostics (AHT?) during boot reveal the VDH002 error which indicates a storage drive issue — from further research, this error could be caused by the SSD chip itself (unlikely in my case), a broken/malfunctioning SSD connector/port on the Logic Board (maybe…), or a corruption within the firmware/EFI chip (possible).

There is another thread discussing the connector and EFI corruption issues here:

Random freezes & VDH002 "There may be an issue with a storage device"

**See answer by https://www.ifixit.com/User/1850118/carl...

posted September 13 for a MacBook Pro with similar issues…**

I have no definitive answer for this problem due to the factors that could cause the issue you’re having, but hopefully this provided some extra information to consider.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Check your connector! I've seen a few of these. Often the connector gets damaged by lifting up the SSD Vs pulling straight out and then up.

Replacing the connector is possible!

da

Aggiungi un commento

Aggiungi la tua risposta

Aashish Agarwal sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 1

Ultimi 7 Giorni: 7

Ultimi 30 Giorni: 20

Tutti i Tempi: 253