Salta al contenuto principale

All about the X20 from Fujifilm announced on January 7th, 2013.

6 Domande Visualizza tutte

Refuses to turn on

For some reason my X20 will not simply turn on. I have charged the battery still nothing Help please

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
Aggiungi un commento

2 Risposte

Have you tried pressing the play button to turn it on?

Questa risposta è stata utile?

Punteggio 0

1 Commento:

Hello Andrew 6, I have same problem and when I press play button it starts playing the photos but the switch is of. If I switch on it will not do anything, could it be this fuse? Thanks in advance

da

Aggiungi un commento

I’ve had exactly the same problem on my X20. I followed the disassembly guide and traced the fault to a blown fuse on the main board, a tiny SMD fuse in 0603 package. I believe this is rated at 2.5A. I’m going to replace it and if it works I will add a replacement guide. Hopefully there are no follow-up faults.

Update (05/14/2020)

I’ve replaced the fuse on the PCB and reassembled the camera - it is working absolutely fine now! I've added steps to the disassembly guide to show where the fuse is located.

Questa risposta è stata utile?

Punteggio 0

1 Commento:

Where is this fuse located? Is thid fuse easily available?

da

Aggiungi un commento

Aggiungi la tua risposta

Angus sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 3

Ultimi 7 Giorni: 4

Ultimi 30 Giorni: 20

Tutti i Tempi: 692