Salta al contenuto principale

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

153 Domande Visualizza tutte

Replaced hard drive, new drive won't boot

I want to replaced the old hard drive. I bought a new Western digital 160 GB 5400 rpm ATA hard drive. I cloned the new drive with a drive enclosure & used SuperDuper. I get an error message that says the drive is not a bootable drive. When I click on the icon of the drive, everything appears to be there, but when I start the computer while holding down the option key I only see the old drive.

Any suggestions? I have reformatted the drive several times & tried to start the computer with the restore DVD's using the disk utilities with no luck.

Risposto! View the answer Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1

Commenti:

I installed the drive, thinking as you that the drive won't boot from the enclosure. Still the same thing, non bootalbe drive message. I put the old drive in the enclosure & that is the only way I can boot my G4

da

Aggiungi un commento

4 Risposte

Soluzione Prescelta

I believe there is a size limit of 128 GB on the boot drive.

If the drive has NOT been formatted using OS 10.2 or latter. Repartition the drive so your boot sector is less than 128 GB. Clone/dupe to that sector and see if it will recognize/boot.

Other solution would be to format and install OS X.x on the new drive then use Migration Assistant to transfer your files.

Good Luck,

N.

Questa risposta è stata utile?

Punteggio 0

Commenti:

I am using OS X 10.4.6, tried your suggestion, re-formatted drive then tried to install OS X, now get a message that OS X cannot start up from this volume. Suggestions? Wrong drive?

da

Not clear - did you make a boot partition smaller than 128GB and install the OS to that? If not do so.

N.

da

The G4 aluminum mas "Large Drive Support" so it doesn't have the 128GB cap like older macs.

da

*has "Large Drive Support"

da

It worked!!! Thank you! I made 1 partition & set system pref to start on the new drive.

da

Mostra 1 altro commento

Aggiungi un commento
Risposta Più Utile

I had to read this question several times to jog my memory as to what might be the problem. Sounds like you did everything right. If you are trying to boot the Book from the drive and it is still in an external enclosure, if it's a USB, it won't work. You either need to install it into the Book or put it in a firewire enclosure.

Questa risposta è stata utile?

Punteggio 3

Commenti:

Reading the OP I think you are on to something. + Ralph

da

This is the kind of question I like, makes you wanna say "Hum"

da

Ok, if you're using a firewire enclosure, put the working drive in it, then the new drive in the machine, then boot from the external and clone it.

da

Aggiungi un commento

I am unsure how relevant my answer is, given that you had no contact with an Intel-based Mac as I did. However, I encountered tons of trouble when I cloned a PowerBook G4 hard drive on an Intel-based MacBook Pro.

From the article above: "By default the Intel-based MacBook Pro set the drive partition to its native Intel-only “GUID Partition Scheme,” which prevents a PowerPC-based laptop to boot using the drive. So I set the 320 GB drive to the PowerPC-native “Apple Partition Scheme,” and of course Mac OS X installed with no problems."

So do make sure that your new drive's partition is set to Apple Partition Scheme, otherwise your PowerBook won't like the drive...

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

Tricky one. Since you have a backup (your old drive), why not try formatting the new drive, installed in the book and install. Maybe that works.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Tried that

da

Aggiungi un commento

Aggiungi la tua risposta

wlambie63 sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 4

Tutti i Tempi: 3,772