Salta al contenuto principale

Fourth generation Samsung Android tablets. Released in April 2014.

357 Domande Visualizza tutte

Tablet won't charge - reboot loop

Hey there,

I've got a tablet here which I offered to repair for free if I could. The issue was that it wouldn't charge so I changed the charging port with the ribbon cable which was obviously faulty.
However, this didn't fix the problem.
I am getting a battery symbol with a lightning which continuously loops.
I replaced the battery then since it showed 3.3V and I expected it to be dead.

With the precharged battery, the tablet turns on now, but it won't charge. The battery is not red crossed.
When the tablet is off, I still get my boot loop with the flashing battery icon.

I've tried hard resets like Power + Vol Down/Vol Up, Home which I found in my research. Maybe there is one I missed, so help is appreciated.
Power down leads to flickering without a battery symbol (0.5s).

I've also had the idea that the power supplies may were insuficient. I used an external power supply to provide at least 5V and 2A (via the USB cable) Those are my observations:
- NO current draw when the tablet is on
- 0.08A up to 0.92A for a short moment when the battery symbol shows up
- 0.08A in recovery menu
- Flickering after powering down: 0.02A (constant)

Now it gets interesting: when the boot loop is started (cable connected) and the display ribbon is disconnected, the current rises from 0.92A to 1.15A (for short moments). So it uses more energy to NOT power the display than to power it.


I feel like there's a software issue but I've not yet found a solution for that. Can anyone help me with that?

Otherwise I see two options:

- Lower the voltage of the charger to 4V and directly connect the battery to it
- Power the tablet directly with 5V without the battery: I've done that with a phone before but since the tablet is not mine I'd prefer a safer option. The owner has agreed on risking it though (before he knew the tablet was starting with the new battery).

Help is very appreciated.

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
1 Commento

Addition with battery voltage:

- 3.97V Stock voltage with the tablet shut down

- 3.90V - 3.97 - 3.99V Boot loop, display connected: mostly discharging, charging for a second -> voltage drops over time

- 3.96V - 3.97 - 4.03V Boot loop, display disconnected: mostly no power usage, charging for a second -> voltage slowly rises over time

By having a swith for the display cable ribbon I'd be able to charge the tablet over night. But how would you achive that? Maybe there's a line for the display backlight which I could make a switch for?

(Surely not the best solution but a better one than throwing the tablet away)

da

Aggiungi un commento

2 Risposte

Risposta Più Utile

Hi @schattengestalt

Here's the troubleshooting flowcharts from the SM-T230 service manual, that may be of some help.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

I had the same issue! It turns out that most of these models has degraded batteries and this is a discontinued version. I charged mine for half a day and it turned on. It is probably due to the low voltage that the battery is receiving.

Questa risposta è stata utile?

Punteggio 0

1 Commento:

Did you charge the battery externally (without the tablet)? Otherwise my problem is different: the tablet/usb connection doesn't charge. The battery was replaced and it powers (and boots) the tablet but we can't charge it.

da

Aggiungi un commento

Aggiungi la tua risposta

SchattengestaIt sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 9

Ultimi 30 Giorni: 36

Tutti i Tempi: 630