Salta al contenuto principale

Aggiusta la tua roba

Diritto alla Riparazione

Store

Modelli A1419 / Fine 2012 / Processori 2.9 & 3.2 GHz Core i5 o 3.4 GHz Core i7, ID iMac13,2

309 Domande Visualizza tutte

Fan is running fast after installing new ssd

Hi iFixt,

My iMac is now running great, much faster after installing new SSD kit (order number UK-473475).

But… the fan seems to be running on full speed (screen shot diagnostics attached). I did attach the new thermal sensor you provided.

I did give the inside a good spray with compressed air, maybe that’s the cause ??? Ouch.

Block Image

Block Image

Any help would be much appreciated.

Cheers

Kevin

Update (08/31/2020)

Not sure how to add screen shot to reply, but error below:


Block Image

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

Commenti:

Error message here:[br]

[image|2191257]

da

Aggiungi un commento

2 Risposte

Soluzione Prescelta

Lets see if the onboard diagnostics gives us a clue. Restart your system and press the D key to enter into diagnostics

Reference: Mac startup key combinations

Did you have a hard time taking the display off or stress the displays ribbon cable?

It’s possible you got a bad thermal sensor assembly. Get a new set of adhesive strips as you’ll need to go back in. But let’s first get diagnostics to help us isolate where to look.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Thanks Dan, much appreciated.

Nuts, the D key results in a white screen, nothing more happens... even waiting for more than 1 minute. I tried option + D, but after showing a promising Internet icon it switched to a black screen and message "Can't load 'EFI/Drivers/TestSupport.efi', screen shot attached.

/Users/kevinmcgee/Downloads/IMG-0678.JPG

Ok this was my 1st attempt at opening an iMac... it didn't go too well I'm afraid, I embarrassingly, cracked the screen, hairline but pretty large, lower right side. TBH I can live with this for another year until I save for a newer iMac.

I do have a spare older early 2011 iMac (old thicker chassis EMC 2429), if I've blown it with the above, do I have any options of installing the SSD I purchased or swap the screen?

Kev

da

Sounds like your display damage is the source of the problem ;-{

Which could be why the system is racing the fan.

As far as diagnostics Apple messed up the systems firmware (EFI) which is why diagnostics failed you.

da

Thanks Dan, oh well... we win some, we lose some... 8 yrs is a pretty decent outcome. It still works, and fast, I’ll turn up Spotify a notch and see how long it survives! Thanks for your help, kudos.

da

Aggiungi un commento

It’s not a big deal, it’s the function after installing

Questa risposta è stata utile?

Punteggio 0

Commenti:

Hi Sanjeev... the fan is very loud and running at 2643 RPM (red lining), even shortly after logging in and with no apps open. Are you sure this is normal?

da

No, you do have an issue here, this is not normal!

da

Aggiungi un commento

Aggiungi la tua risposta

kevin mcgee sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 1

Tutti i Tempi: 51