Salta al contenuto principale

MacBook Booting From USB By Default, Keyboard Not Working

I apologize for the length of this post but I wanted to be thorough. I have a 2009 MacBook Pro that someone gave me because they spilled coffee on it. It ran, but the keyboard typed in like Webdings until I pressed the Fn key, then it kind of worked but the Delete, Command, and Option keys didn’t.

I bought a replacement keyboard and installed it, along with more RAM and an SSD, since I already had it open. I thought I could just boot from a USB device and install OSX on the SSD from there, but it didn’t work so I swapped the original HDD back in. The keyboard worked fine the first try and booted into recovery the first time I tried, but when OSX booted up the keyboard stopped working correctly. Caps Lock is on permanently now, and the delete key still doesn’t work. I don’t think Command and Option keys do, either, so I can’t change my startup disks after a restart.

That’s to preface this by saying I can’t rely on the keyboard to boot into Startup Manager or Recovery Mode. I plugged in a USB keyboard to use with the HDD, and attached an SSD via USB as well. I installed El Capitan onto the SSD then swapped the drives out, but I got the “prohibitory” symbol. When I plug the SSD back in via USB, WITHOUT a disk attached to the Mac SATA cable, it boots into El Capitan from the SSD. If I reconnect the original HDD to the Mac SATA cable and change the startup disk in OSX to boot from the original HDD, that works.

Why can’t I just connect the SSD to the Mac SATA cable and boot from there? And how do I fix the dadgum keyboard? If the options key doesn’t work I’m not sure what to do next.


Edit 1: Here is a picture of the error I was getting while trying to install the OS on my SSD, via USB:

Block Image

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
1 Commento

Replace your SATA cable with a new one and see if that helps


Aggiungi un commento

1 Risposta

Risposta Più Utile

You have some conflicting diagnostic processes here.

I’m suspecting the SSD’s format was not setup correctly. You need to format a raw drive with GUID either with HFS+ (Journaled file system) or APFS (if you are using High Sierra or newer). So with an older model you like this one we can mess up without realizing using a newer Mac to prep the drive! Here we need to use HFS+ as the system has no means to support APFS.

Questa risposta è stata utile?

Punteggio 1

3 Commenti:

Thanks for the response. I used my WIndows 10 computer to format the drive as GPT, then tried installing El Capitan onto it. I kept getting an error until I manually rebooted the Mac but then the installation completed. I'll post an image of the error in a sec.

I'll reformat the SSD using the old OS on the original HDD and try again.

Do you have any advice on the keyboard? Does it sound like a software issue?


The drive was already set up as a Journaled file system. So the SSD is booting via USB but not via the internal SATA cable.


Who's SSD and model did get?

The CPU crash is telling you have more damage on the logic board from the liquid spill.


Aggiungi un commento

Aggiungi la tua risposta

Zebediah Jenkins sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 1

Ultimi 7 Giorni: 3

Ultimi 30 Giorni: 11

Tutti i Tempi: 447