Salta al contenuto principale

Repair information for KitchenAid dishwashers.

19 Domande Visualizza tutte

Dishwasher starts and stops

I have a KitchenAid dishwasher (KDPE234GPS) that will start washing but the pump shuts off after about 2 seconds. Self test shows a code of 4-3 indicating a problem with the wash pump circuit but both the pump and the control board have been replaced. Still has the same problem. The pump starts for only about 2 seconds and then shuts off. It seems to repeat that several times but the wash pump never run for more than 2 seconds.

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
10 Commenti

Hi @sweigner ,

Did you check the wiring between the control board and the pump for any loose or corroded connections etc?

da

I cut the wires near the control board and applied 120vac to the motor wires to test the wiring and the motor. It seemed to operate normally (pump water continuously).

da

I have a Kitchenaid KDTE104ESS4 and have exactly the same problem. I've replaced the entire sump assembly, control board, control panel, turbidity sensor and checked all wiring and connections still nothing! Pump starts for a second then shuts off. Repeats several times. Any update?

da

I have the same problem - seems like the pump is switching off after a couple of seconds in cycle. Error codes 4-3 and 6-4 so I just replaced the circulation pump but to no avail. Wondering if anyone found a fix for this? I have a Kitchenaid KDTE204DSS0

da

I hv Kenmore 665.13839K600. Have same problem seems like post start water turn filled.... pump switch off after few sec.when is press cancel buttons pump starts agin and shutdown in Few sec again...u can do this as many times as I want while pressing the cancel button..in the end when I press cancel long time it srauns aater.

Please assist?

da

Mostra altri 5 commenti

Aggiungi un commento

4 Risposte

Soluzione Prescelta

Hi @Ray Benefield,

Sounds as if there may be a problem with the circulation pump or perhaps the power supply to the circulation pump motor.

Also have you checked that the holes in the spray arms are clear and unobstructed?

Disconnect the pump from the wiring harness and try connecting power directly to the pump and see if it runs smoothly or not. Be safety aware as the pump operates at mains voltage supply.

Alternatively use a voltmeter to check if the pump power supply is steady but the pump turns on and off.

Here’s a link to the parts for the dishwasher that may help. There are other suppliers online that may suit you better. just search for KDPE234GBS0 parts to get results.

Also check behind the kick plate (toe plate?) to see if the tech sheet is there in a plastic sleeve. The tech sheet details how to get into the diagnostic modes for the dishwasher so all the functions can be individually tested etc. Hopefully it also has the wiring diagram as well. Maybe running the diagnostics will give an error code which may have a better explanation of what is happening

The tech sheet part number is W10904612 (I think that this is it) just in case you don’t have one with the dishwasher

Questa risposta è stata utile?

Punteggio 1

7 Commenti:

Has anyone found a solution to this problem? My pump motor is fine. Just replaced. Wiring fine. 4-3 code. Pump and spay starts. Can me heard. Then stops and then starts for 2 seconds then stops again. Keeps doing this and never stays on. Will eventually complete the cycle but dishes not clean and soap still in bottom of dishwasher.

da

Has anyone found a solution to this problem? I just had a repair tech replace the wash motor and it only comes on for less than a second than stops. Tech is saying it is most likely a bad computer, but wouldn’t computer throw errors?

da

This is a shot in the dark- try replacing the thermal fuse. you can find them for under $10 on Amazon or Ebay. I have not had the issue described here, but i have a Kitchenaid DW and this has resolved a few head scratchers.. i now keep a couple on hand! it’s a 10-minute replacement job.

da

I had an 4-3 error (wash motor not turning on). replaced wash motor but the motor would only turn on for 5 sec, off for 5 sec & repeat. Fixed this secondary problem by putting it into diag mode, let it run it's full course in diag mode (~ 20 mins), started a normal wash, let it run it's full course in normal wash (still pulsating on/off every 5 sec | ~ 1 hour), and then started yet another normal wash mode and it's running like a top!

da

I had the same problem. Solved by using manufacturer specified pump rather than Amazon or ebay "OEM" pump (which I did buy initially). Many newer dishwashers use 120v/0.9A to kick-start the pump but drop down the power to 55V once started. The Amazon import pumps need constant 120v, which is why they run for 2 seconds during the kick-start and then stop.

da

Mostra altri 2 commenti

Aggiungi un commento
Risposta Più Utile

I had the exact same problem. Turns out I used the wrong replacement pump. It looked the same and fit properly, but would only run for a 2 to 3 seconds before stopping. It is an easy mistake to make, especially with all of the model and part number variations on the internet. Just FYI.

Questa risposta è stata utile?

Punteggio 2

1 Commento:

Thanks, I got tired of messing with it and found the same model at a steel so I just replaced it. Got tired of wasting money and replacing parts. I did replace the motor one and then sent that back and purchased a whole new sump assembly with the motor and still wouldn’t fix it. All and all, very disappointed with kitchen aid. Spent the extra money when we redid our kitchen on all matching kitchen aid appliances and every sing one has had problems. Total junk

da

Aggiungi un commento

I had the same problem. Solved by using manufacturer specified pump rather than Amazon or ebay "OEM" pump (which I did buy initially). Many newer dishwashers use 120v/0.9A to kick-start the pump but drop down the power to 55V once started. The Amazon import pumps need constant 120v, which is why they run for 2 seconds during the kick-start and then stop.

Questa risposta è stata utile?

Punteggio 2

2 Commenti:

So the problem is I bought OEM parts both times. The first sump pump assembly didn't work. 2nd did and solved the problem. Can anyone explain that? Only explanation I can arrive at is QC/ poor quality parts at the factory.

da

Seems to be there are two different parts that both fit and look almost identical. I also bought two OEM parts, first didn’t work, second did. The part that worked, W11084656, was slightly smaller than the one that didn’t, W11032770.

da

Aggiungi un commento

Hi @sweigner ,

According to this link the dishwasher has a diverter motor as well as a pump and motor assembly

I don’t know if they are combined and when you replaced the pump that this motor was also replaced or not, but if it was not and it was faulty the dishwasher would stop when the wash cycle begins.

Perhaps you could check its’ operate path if it was replaced when the wash pump unit was replaced

Questa risposta è stata utile?

Punteggio 1

1 Commento:

Sump assembly came with a new diverter pump as well. When run diagnostic it still shows code 4-3.

da

Aggiungi un commento

Aggiungi la tua risposta

Scott Weigner sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 13

Ultimi 7 Giorni: 83

Ultimi 30 Giorni: 376

Tutti i Tempi: 18,416