Salta al contenuto principale

Lanciato nel giugno 2009 / processore Core 2 Duo da 2,53 GHz

170 Domande Visualizza tutte

I cloned new SSD, installed, works for 2 hours then screen goes black

My problem is this:

I Installed a new SSD into my mid 2009 MacBook Pro.

At first it was working great, then after watching some video's, screen went black, after the cursor just spun and spun. sometimes after going black I'd be able to move the cursor sometimes not. after a force shutdown, and restart, then I'd get the circle with the line, or the question mark.

I put back the old drive, worked perfectly. it was suggested to change the hard drive cable, which I did, and surprised how easy it was, booted up the computer, all excited, and after using after a couple hours watching video from same site (mypoints.com) the same thing happened! So i reinstalled old drive, and booted up the new drive from an enclosure, but not a 3.0 (not sure if that matters) and it worked flawlessly the rest of the day...

Now I have the old drive in, and I'll know if it works like is used to, as I'm sure it will...

I really don't want to have to just keep the external attached to use.

Please help... I'm also thinking about bringing it in. I even bought a folding laptop stand with fans in case it was getting to hot, and it happened again …


Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
4 Commenti

What is the make and model of the SSD you put in?

da

Did you copy the original drive to the new one?

da

Caliber - Eric Cloned the drive which is a copy of the original drive.

I personally don't use cloning apps any more as they are passé. They often create more problems than their worth. I only use the built-in Migration Assistant tool it never fails!

But thats not the issue here, there is something hardware wise thats amiss.

da

i tried to use the migration assistant, but it just searched, and searched for the drive and couldn't find it... so originally i just cloned the drive, and when it happened, i used time machine, and it happened again... still happening...

da

Aggiungi un commento

3 Risposte

Soluzione Prescelta

I’m suspecting you are using either the wrong SSD - A fixed SATA III (6.0 GB/s) drive Vs a fixed SATA II (3.0 Gb/s) or using an auto sense drive which matches the systems I/O which in this case is SATA II (3.0 Gb/s).

As a matter of course I always replace the HD SATA cable when I put in a new SSD. Even in the older SATA II systems. Here the over flexing of the cable weakens them and the rough aluminum uppercase can wear them as well. The issue is the intensity of the data flows is higher with SSD’s than HDD’s so while the HDD works the SSD will often fail!

Questa risposta è stata utile?

Punteggio 0

4 Commenti:

Makes sense, because the external enclosure worked and that data throughput is lower. In the past I've never had to replace the SATA cables on any MacBook Pro I upgraded to an SSD. Then again maybe the Crucial drives I chose are ones that match with the I/O requirements. Thanks for the info.

da

i have 2 ssd in my amazon cart now... one is the samsung evo other a crucial... crucial is under $50 and about $10 cheaper. i might just give it a shot to see what happens... i have a ps4 i can always use to replace THAT drive with..

da

@reddskullz - I would personally go with the Samsung as its guaranteed to work in the older SATA II (3.0 Gb/s) systems whereas the Crucial only supports SATA III (6.0 Gb/s). Just review the spec sheets.

da

ok thanks dan... will do...

da

Aggiungi un commento

Sounds like the only thing you havent tried is to actually replace the SSD. It seems to be the culprit from the description you gave.

Questa risposta è stata utile?

Punteggio 0

3 Commenti:

i'm thinking about doing that... maybe trying a samsung evo... just today i used the new ssd in an enclosure for a good 5 to 6 hours with no problems,,,

da

I've had great luck with Crucial SSD's over the years. Hopefully, there isn't something else going on since you had success with it running externally.

da

that's the 1 thing stopping me... it's not like having these is a waste, BUT, no reason to buy it if i KNOW it won't work.. i'm also considering just trying another hdd drive just to see if it works.... thanks for trying to help brian.. :-)

da

Aggiungi un commento

but still, does anyone have any other suggestions of what it might be? should i reset the SMC? would it hurt to do it if it’s not needed? or should i reset the nvram, and would it hurt to do it if not needed? i did also replace the battery recently….

Questa risposta è stata utile?

Punteggio 0

11 Commenti:

So what happened when you put in the new SSD?

● Did you also replace the HD cable as well?

● Did you format & install the correct MacOS version onto the drive?

da

everything is, was done right. wqas working for couple hours when black screen happened... then wouldn't boot back up... change back to old, works fine...i originally replaced my battery, then i went and did the SSD and that's when i started having the trouble

da

You are facing a classic case of a bad SATA cable and/or you are using the wrong SSD (SATA III instead of SATA II) if your HDD works and is stable then you switch to an SSD and this happens.

If thats not going to work then you'll need to stick with your HDD until you can get someone to help you directly.

da

i gotta think the chance of me getting a new cable, and that one being bad as well is pretty small... the sata cable is the hard drive cable, correct? and i'm 100% sure i'm using the right SSD... i checked, double checked, and even triple checked with a tech from OWC... i believe i even read off to you what it said...i'm pretty sure i have a 7200 rpm hdd around here somewhere... i might try going with that, and that'll be better than what's in there now

da

You need a new cable! And you need to not damage it in the process. I've seen new cables killed in 5 seconds! Don't fold it that kills it.

da

Mostra altri 6 commenti

Aggiungi un commento

Aggiungi la tua risposta

eric k sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 3

Ultimi 30 Giorni: 17

Tutti i Tempi: 334