Salta al contenuto principale

Complete repair manual for the PSP Go, including battery upgrade and display repair instructions.

83 Domande Visualizza tutte

Loss of audio Output From Units speakers.

Hi,

I have my psp go doing an odd thing.

It powers on fine and all functions are correct - save one. Audio.

Initially i susected that the device was assuming thati had headphones in - but when headphones are inserted the volume changes ion screen to the volume i had set last for headphones and audio is outputted through the headphones.

I then suspected that there may be dirt in the dock and thourghly cleaned the dock. Still no sound from speakers.

I then stripped PSP down as per your guides and looked at the speakers themselves - visually nothing "seems" wrong.

What areas should i be focussing on to rectify this fault?

Is it possible the speakers have blown after a heavy bout of dance/trance bass?

If so where can i obtain replacement parts?

Thanks in advance

Coxy

-EDIT-

Reading other psp go problems i found this fuse diagram.

http://www.mr-vizitkin.ru/images/stories...

I dont speak/read russian and dont know if these fuses are relevant.

Anyone care to share a translation?

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
Aggiungi un commento

5 Risposte

Soluzione Prescelta

SOLVED

It is a piddly little fuse on the right side of the motherboard as you remove rear case.

It is marked with the letter L.

My fix is more of a bodge tbh.

I desoldered the fuse and used a bit of thin wire to make the circuit.

to make the fix permanent i need a new fuse lol.

Anyways hope this helps someone out in the future

Questa risposta è stata utile?

Punteggio 2

Commenti:

Great job, now all you have left to do is to accept your own answer. That way we will know that this works. Again, great job.

da

Fuses blow to protect the rest of the system. By bypassing it you risk serious damage

da

Here's what mine looks like (I desoldered those three little fuses):

https://i.imgur.com/SF8DQyg.jpg

When I get some thin wire soldered over the contacts to make the circuit, the PSP stops booting up. I take it off and it goes back to working (yet with no sound).

This is literally my first time using a solvering iron, so I'm wondering: is it possible that my board has gotten so messed up to the point that I'll no longer be able remake the circuit? Or am I just not soldering the contacts together correctly, and therefore should keep trying?

da

Aggiungi un commento

I had the similar problem and by repairing the fuse problem solved.

Thanks Coxy.

Questa risposta è stata utile?

Punteggio 1

Commenti:

How exactly did you repair the fuse?

da

Aggiungi un commento

Im having the same problem here. No sounds through speakers. Earphones works perfectly.

I didnt silde the fuse of but I tried to connect 2 sides of a fuse with a wire but when they were connected the psp didn't boot up. when I remove the wire everything works again but still no sounds

is there anyway I can check if its really a fuse problem or not ? I'm just a noob so please help xD

I know this is an old topic but please help me !

Thank in advance :)

Questa risposta è stata utile?

Punteggio 0

Commenti:

Same thing is happening to me :\

da

Aggiungi un commento

i replaced the fuse. now my start/select button don't work. You think related ?

Questa risposta è stata utile?

Punteggio 0

Commenti:

What did you replace the fuse with?

da

Aggiungi un commento

^ you might have not have done it correctly.

Make sure you didn't leave any residue around the components. It can cause faulty things to happen.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Coxy sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 1

Ultimi 7 Giorni: 11

Ultimi 30 Giorni: 59

Tutti i Tempi: 11,325