half of my screen is pink (only when dark colors suppose to appear)

I have a LG 42LD550 TV screen. the right side shows pink color instead of dark colors (when there are bright colors it works perfectly).

I have replaced the flex cables and it didn’t help. What can be the faulty component? can i buy it on ebay (or another website)?

Block Image

Block Image

Thanks.

**I added photos of the back and the top of the screen

Block Image

Block Image

**update2: photos of board

Block Image

Block Image

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
Aggiungi un commento

1 Risposta

Risposta Più Utile

@dodom usually when one side of the panels is out this could be related to the loss of drive data for RGB information to the left side of the screen. This is sometimes caused by the flat cable connecting the TCON to the LCD panel coming loose or having been damaged. The area of missing video can be dark or completely white depending on the panel design.

So, check your cables and if those are seated properly and show no damage, your most likely failure is the T-con board/connector or the LCD driver board (part of the panel). we would have to see more of the actual panel of your TV and the driver boards. You recognize those by looking at the top of panel for the small ribbon cable entering the panel. There are most likely 4 ribbons per side per board. Check on those ribbon cables and with the TV connected, tap each one of those ribbon cables and see if that will correct the color issues. Post some images of your Panel etc. with your question. That way we can see what you see.

Update (11/09/2018)

@dodom it would be the boards and the end of either one of the ribbon cables. There will be most likely 4 cables from each board go into the panel. Tap those cable ends and see what happens. Looks like you have a frame around the display so you may have to loosen it or take the panel out to get to them

Block Image

Questa risposta è stata utile?

Punteggio 2

Commenti:

Thank you for the quick answer @oldturkey03 !

I added two photos to the original post of the back and the top of the screen. The cables that mark in red are the cables that i have replaced (i have switched between the two of them and the problem still remain in the same side, so i believe that the cables are ok).

Im not sure what are the ribbon cable so i hope that the new photos will help.

Thank you!

da

@dodom it would be the boards and the end of either one of the ribbon cables. There will be most likely 4 cables from each board go into the panel. Where the tap those ends and see what happens.

da

thank you again @oldturkey03 .

i have added 2 new photos of the board and the cables.

i tried to tap it while the tv is on but nothing seems to change. so i believe that the board itself causes the problem, am i right?

if so, is it easy to replace it? is it suppose to be expensive?

thanks a lot!

da

The LED driver boards are actually hard to replace and hard to obtain. Let me see if I can find out more about those.

da

@oldturkey03 do you have any news for me maybe? :)

da

Mostra altri 2 commenti

Aggiungi un commento

Aggiungi la tua risposta

dodom sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 0

Tutti i Tempi: 68