Wont' turn on after screen replacement

Hi

I've just replaced an SP3 screen. I've done a number before without issues.

Prior to replacement the screen was cracked and the display froze on the surface boot logo. Sort of as if the bios were engaging but couldn't find the drive to load up the OS.

prior to removing the screen I waited until the battery was dead and then went ahead. the screen came off relatively easily, no trauma to any cables apart from the digitiser, which was dead anyway. in cleaning the edges of adhesive I tore the copper strip on top of the USB port - but that's replaced now and certainly no damage to the physical port underneath.

I now get no response from the hardware at all. no screen light, but also nothing hardwareish like the fan going or the processor warming etc.

I've tried hard resets and i've tried booting to UEFI and to a usb image. all without any noticeable change. this is not a DOA screen as the old screen is exhibiting the same behaviour.

the charge port works fine. I've measured the voltage of the battery before (7.4v) and after (8.7v) charging and the top right of the tablet gets warm after a chunk of time on charge. the keyboard lights up as well; and is responsive to the caps and Fn keys (the light turns on and off).

any clues about where to search for issues? Anyone know where I can find the circuit schematics to trace the power lines?

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 4

Commenti:

My surface Pro 3 had the LCD screen broken but still turn on . No possibility to use fingers in the screen but works with the keyboard and mouse. I bought a new one through Amazone . After removing the old LCD as shown in several youtube video I disconnect the 2 flat cables. Just 2 miserable flat cables! Connecting new LCD. Impossible to get on . No boots, no fan on, no lights on the keyboard. Nothing in the screen : BLACK. I charge the battery(the power connector shows the light on). I disconnect the battery from MB and test the Voltage . Seems ok 8.3 Volts . Check every connector. All in right position.

? why after a simple LCD replacement the surface do not turn on? look very strange. Could be some kind of "protection" from Microsoft to prevent any one of us to replace o repair a Surface, to force us to send it to the Microsoft service???

Any one have an Idea to solve this? Do I have to forget this matter and accept that I lost 170US$ cost of the new LCD replacement from Amazone.

Thank you.

da

I am at the same situation but with a surface pro 2, replaced the display and a black screen is the only thing I have.

da

Man I could really use some help. I've done many sp3's in my time, but this one...wtf? I have the same issue as both above. Digi was frozen. pulled screen off with the lcd still lit up. Unplugged the battery before removing the screen. Now it will not power on. Solid light on charger. Trying the rubberband thing mentioned below with my fingers crossed. Any solutions yet?

da

Aggiungi un commento

Spedizione gratuita per tutti gli ordini superiori a 100 US$ o contenenti un Kit Attrezzi Pro Tech!

Sfoglia il Nostro Negozio

8 Risposte

Risposta Più Utile

Plug your surface into an external monitor.

It seems your ribbon cable for the screen is fried.

It will work plugged into a tv with a mini display port to hdmi cable.

When your screen broke and you booted it up without a decent working screen the driver snafu ed itself.

I've had this happen many a times.

After you get the new ribbon cable. Do a fresh install of windows with fresh drivers from Microsoft website.

Questa risposta è stata utile?

Punteggio 1

Commenti:

So in general if you boot the surface up without a screen attached you need to reinstall windows?

da

The LCD flex appears to have been my issue. I am order new flex and spacers to see exactly what is wrong, but I plug it up to an external screen and it's on.

da

I'm having a similar issue. Digitizer works fine and I can connect to an external monitor. I have no video on the screen. Did the LCD flex cable fix your problem?

da

Not yet, I am gonna order the LCD spacer when they are available and try it too. Just got new flex in today and still a no go unfortunately

da

It was the LCD spacer!!!

da

Mostra 1 altro commento

Aggiungi un commento

Curiously I have replaced the motherboard with a known good variant and it is still refusing to turn on. Two different screens and two different motherboards. The only commonality is the power switch and the battery.

Battery appears to charge adequately. So I assume it is functional.

Very odd.

Questa risposta è stata utile?

Punteggio 0

Commenti:

did you manage to fix it?

da

I had that same issue. There is a little plastic shim with gold contacts that fits between the video ribbon cable and the logic board at the connector. Without it, the logic board video connector contacts will not connect to the LCD video ribbon cable. I managed to find where mine went and after inserting that shim between the cable and board, works as expected. Best advise would be to disconnect that cable at the LCD and leave it connected to the board. It looks pretty fragile too.

da

i have the same issue but all connectors also the smalls contacts are in same position and everything and doesn't turn on please if this was fix or there's something else email me please

da

The "shim" answer saved me from discarding a Surface 3 that wouldn't turn on after LCD replacement. Is there a shim under the battery cable also? The battery is working and there isn't one under its connector.

da

Aggiungi un commento

Did this ever get resolved? I've got the same issue after I removed my screen. The shim is on the power connector. I get no power to the device whatsoever.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Nope. Never resolved.

I think the answer lies in a mosfet blowing. But without the schematics it is very difficult to tell. I've tested all the resistors and fuses on the boards that I have and they all seem to be conductive, although of course without schematics I cannot tell whether there are any that are partially failed and therefore at the wrong value.

If anyone has copies of the schematics online I can test further.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Thanks for the reply. I thought you tried a different motherboard. Is the mosfet located in another location? This is a frustrating problem, worked fine, remove screen, no longer works. And I was careful!

da

I've got a similar problem with the Regular Surface 3. I replaced the screen once for a client, a few months later she needed a new one, and this time I get 0 response from the device other than power cycling through the battery properly. According to my meter anyhow. I do wish I could get a schematic or something as well, this is driving me crazy and she wants to pin this one me! D:

da

Thought I had the same issue. Do a "hard boot" on the unit. Hold the volume button (I did volume up I think) while holding the power button. Similar to iPhone hard boot (home + pwr button

da

LCD spacer fixed my issue that I had like this

da

Hi Richie. Please could you describe to me what is LCD spacer? Thank you . Joseph Bentolila

da

Aggiungi un commento

I lost the LCD contact shield plate when putting on the new display (alias shim referenced above). I have been unable to find where to buy one and was ever so hopeful someone could direct me to a source.

Questa risposta è stata utile?

Punteggio 0

Commenti:

If anyone has a used one I would be glad to buy if off you if the price isn't too high.

da

Aggiungi un commento

I just fixed my black screen by replacing the LCD spacer between the flex and the board!!!! It works again!!!!

Questa risposta è stata utile?

Punteggio 0

Commenti:

Where did you find the spacer? I have lost mine!

da

Aggiungi un commento

I have removed and replace the battery leads and the SP3 still indicates that there is no battery installed. I received another new battery and installed it and the same scenario! It just doesn’t recognize the battery. When I took it apart, all was working fine. When I put the broken screen in, it still works… When I put the new screen in, it still works. But both batteries are showing on the screen, that there is no battery installed.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Did you lose the battery spacer? It's the rectangle bridge between the mainboard and the battery connector.

da

Aggiungi un commento

I highly suggest going over the pins and contact plates for the display and battery connector. I had the same issue with a repair and it turns out one of the pins for the battery contact board ended up being scorched.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Justin Adie sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 17

Ultimi 7 Giorni: 50

Ultimi 30 Giorni: 165

Tutti i Tempi: 1,810