Salta al contenuto principale

The Sony Xperia Z5 Android smartphone was released in October 2015. The Sony Xperia Z5 features 5.2 inches 1080 x 1920 pixels display and is equipped with a Qualcomm Snapdragon 810 processor alongside 3GB RAM and a 23 MP rear camera.

72 Domande Visualizza tutte

My phone won't charge.

My phone was working fine this morning but when I plugged it in to charge (It was around 10~15% battery) It would detect the USB cable but it wouldn't charge. It would vibrate and the "low battery" notification would disappear but it won't charge. So I turned it off and left it plugged in to charge.

Things I've done:

[Power button + volume up]

- vibrates 3 times

- red light (turned blue the first few times)

- shows SONY XPERIA white screen

- shows battery screen + charging sign on top of the battery thing but it doesn't charge, no battery percentage shown

[Yellow button + removed SIM card and memory card]

- red light

- shows SONY XPERIA white screen

- shows battery screen, no charging sign but battery percentage is shown (0%), not charging

- no light while plugged in

now..

- red light

- SONY XPERIA white screen

- no light

- red light

- battery screen + charging sign, no battery percentage, not charging/battery not filling up

- screen goes blank, no light

- this keeps repeating while the phone's plugged in

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

Commenti:

Got the same problem, when i plug the usb into the phone it makes sound but doesnt indicate/show that its charging. Not even when the phone is turned off. Itseem to be charging but dunno why it doesnt show in the bar.

da

did u find any solution for this… have to same problem with my z5c….

da

Aggiungi un commento

5 Risposte

Could be your battery is old. I had an iPhone with the same issue after 1 year. I had to replace the phone.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Aww darn. I gotta get it checked then.

da

Aggiungi un commento

You have to replace the qualcomm power management chip and charging port, I had the same issue and I now diagnosed it.

Questa risposta è stata utile?

Punteggio 0

Commenti:

Does it work

da

Aggiungi un commento

I’ve tried to charge it using my PC USB port and it really works. Please try this and let me know if it will be helpful for anyone.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I have the same issue replaced my chrging flex but still not charge

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

UPDATE:

After letting it charge to 100% on the official charger, I played with it a bit to drain the battery (only down to 97%) then plugged it in with a generic charger, and cheapo USB cable, and it’s charging fine. So, anybody else having this problem, I suggest using the official sony quickcharge charger and usb cable that came with your phone, let it charge to 100%, and then use as normal again afterwards.

Original response:

This is the stupidest thing ever, but the fix that worked for me was to use the original sony quickcharge 3.0 charger and the original sony micro usb cable.

I tried different combinations of cables with the original charger. It didn’t start charging again until I used the original cable. It shouldn’t be this hard, and it’s only by dumb luck that I still had the original cable, and charger.

I had exactly the same problem and went through the same steps as OP. Eventually I tried the “simulated battery pull” (hold power + volume down while charger is disconnected) several times and gave up. On another site someone had mentioned that when the light is blue after holding power + volume up, that means it’s charging, so I left it like that overnight, and to my astonishment, it turned on this morning with a 47% charge (this was using the off-brand cable, and generic charger)

I plugged it in again after it powered on, and it vibrated, but the charge symbol isn’t there. Again, only thanks to dumb luck (and never throwing anything away like a dirty hoarder) I stumbled upon the original charger, and thought it was worth a try, so I plugged it in with the same cable I had been using - again it vibrated, and did not charge. So I thought god, everything I have is usb C now, where am I gonna find a micro B cable? to try a different cable, and the first one I found was the original sony cable. I only knew it was the original because it still had the little wrap-around, sticky tag that says, “sony” on it. I plugged it in with the original cable, and charger - the charge symbol came on like nothing was wrong.

I do suspect sony has baked some prorietary BS into the firmware to not allow unofficial chargers / cables to work without the device being connected to the original charger at least once every 50 - 100 charge cycles? I’m going to let it charge to 100%, then try different combinations of chargers, and cables and report back with what works after letting it charge all the way on the official equipment.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Rina sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 15

Ultimi 30 Giorni: 49

Tutti i Tempi: 4,287