Pentium M 1.6 GHz, 512 MB RAM, 40 GB HDD

22 Domande Visualizza tutte

Why can't I turn on the laptop?

I've been unable to power up the laptop. Not sure why, but I do know someone turned off the power to my AC adapter (my battery died a few months ago, so I don't use one) and I haven't been able to turn on the laptop ever since.

When I connect the power cable to the laptop, the power symbol (the two-pin head icon) lights up. However, when I press the power button, nothing happens and the two-pin head icon goes out. If I remove the power cable and plug it back in, the symbol lights up again.

Anyone think they can help?

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 2

Commenti:

Were you able to resolve your problem? I am having the exact same issue. Thanks.

da

momocha, that question has not been answered since Nov 2010. You get better help if you ask your own question, it is not difficult to do and anybody will se you asked for help. Good Luck

da

Aggiungi un commento

Spedizione gratuita per tutti gli ordini superiori a 100 US$ o contenenti un Kit Attrezzi Pro Tech!

Sfoglia il Nostro Negozio

5 Risposte

Risposta Più Utile

Try unplugging the laptop (normally you'd remove the battery also, but you've got that covered!) and holding down the power button for a good 10 seconds, then plugging it back in and turning it on. I've straightened out several Thinkpad / Lenovos that way when they exhibit the symptoms you describe.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

Could be a RAM issue. On this model I believe that there is one stick on the bottom and one underneath the keyboard. Try removing one at a time to see if either might be causing the problem.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

Same Problem i had back then with another Laptop. It was some dried-out condensers in the near area of the power jack.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

your laptop had a Short circuit!

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I got my IBM X31 fixed with the same issue. Turns out to be that the connections on the port needing bending back into shape and spraying with switch lubricant. Now it works fine.

Try applying pressure on the power connector to see if power comes on intermittently. If so, it might be the same issue as mine.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Jonah Sun sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 1

Ultimi 30 Giorni: 9

Tutti i Tempi: 6,578