Replaced screen and digitized, now touch malfunctions.

I recently replaced the screen and digitizer on my Moto X Pure, but after I opened it back up to secure the screen to the frame a bit more with a little extra adhesive tape, the touch started to malfunction. To clarify, the screen worked fine at first, but something I did the second time around caused it to work incorrectly, e.g. ghost touches, inaccurate touch response and an area at the bottom of the screen around the home row not responding at all.

Any ideas as to what may have caused this? Could the back of the screen assembly behind the metal guard (the piece located beheath the CPU) be dirty or have a piece of adhesive disrupting it? It seems like it must be something small, but I just don't understand digitizers well enough to diagnose what's happening

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

Commenti:

I think the behind digitizer needs to be covered with yellow tape a.k.a kapton tape to insulate it from any external interference.

Similar to insulating like this on an iPad mini glass / digitizer / touch screen:

http://www.ecever.com/media/wysiwyg/iPad...

da

I'm not sure tape is the problem. Here's a video showing what I mean.

https://youtu.be/fdUhjj8ahLc?t=3m23s

Here he has the same kind of replacement I bought, were you have to remove the old screw frame and attach it to the new screen. He doesnt seem to use ant insulating tape, and like I said my replacement screen worked fine the first time. He also doesn't even seem to put the metal cover plate back in between the screen and the CPU.

da

I recently replaced two Moto x Pure screens and had issues with ghost touch with both digitizers afterward, did you ever find a useful tip or any more information?

da

Aggiungi un commento