Battery not charging, MBP only boots with charged battery.

Howdy all, hoping someone can diagnose my problem. I have a Mid-2010 13" MacBook Pro that will not charge the battery, nor will it boot WITHOUT a battery installed (I was under the assumption that all MBP's could boot when connected to a power supply without a battery installed). Here's the scenario: Plug in MagSafe power cable, get green light which never changes to amber. With a charged battery, the MBP will boot. System profiler shows that the battery is discharging, even though the battery icon in the menu bar shows a lightning bolt symbol through it. Coconut Battery confirms that the battery is discharging even when the MagSafe cable is plugged in. If I remove the battery and try to boot the MBP, I still get a green light on the MagSafe connector, but the MBP will NEVER boot. Here are the steps I've taken to attempt to remedy the issue: Performed an SMC reset (at least a dozen times). Reset the NVRAM (at least a dozen or more times). Replaced the MagSafe DC-in board. Tried two known, working batteries (pulled from my daughters' 2010 MacBook Pro's). Tried two different, known working Magsafe power supplies, one a 60W unit from my daughter's MBP, and one an 85W unit from my own 15" MBP. Here's one other observation: When I connect and disconnect the MagSafe power supply from the MBP, the display dims and brightens accordingly, just as it should. The battery icon also displays correctly (solid battery icon when power disconnected, lightning bolt through icon when power connected). Any ideas?

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0

Commenti:

Your questions not being ignored, I just don't have an answer. It should have booted without the battery with the 85W.

da

Aggiungi un commento