Boots fine, login screen is streaked through the middle.

About a month ago I replaced my hard drive, not sure if the two are related, but it worked fine for a few weeks, I upgraded to snow leopard and was very pleased. then one night it freezes, and ever since it boots fine, then at the login screen there is streaks across the screen through the middle. Sometimes I am able to log on, but after any other function or about 30 seconds it freezes. I know it's hardware because i targeted and the software functions fine. Any ideas? is it the harddrive? logic board??

Risposto! View the answer Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 0
Aggiungi un commento

5 Risposte

Soluzione Prescelta

So, after some research and some help from lemerise, I found that this problem is fairly common with the ATI radeon X1600. I found some screenshots that look exactly like my problem. Solution? Replace the logic board. at least a $500.00 fix. Apples recommendation? Buy a new computer. Bummer! Thanks for all your help. Guess I'll start saving!

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento
Risposta Più Utile

Yes the GPU seems to be the culprit. Do you have the Nvidia GeForce 8600M GT graphic chip ?

Questa risposta è stata utile?

Punteggio 1

Commenti:

No, It's the ATI Radeon X1600. I did another teardown just to make sure everything was buttoned up right and aftwerward I still have streaks but I can use it without it freezing unless it sits idle for any extended period of time. Strangely, on youtube for example a video played in the browser has streaks through the browser, but when i enter fullscreen they go away! so next step in try replacing the GPU?

da

Aggiungi un commento

Try running the apple hardware test

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I agree with rab777hp582 about the AHT, but personally, I've never had it pinpoint a hardware problem. So I don't consider it definitive if it finds nothing wrong.

You can rule out the hard drive by booting to something else--the system DVD (such as when you use it to run the hardware test) or an external drive. If you still have problems, then it's some other part of the hardware.

Make sure you've done the requisite resetting of the SMC and zapping of the PRAM.

http://support.apple.com/kb/HT3964?viewl...

Sometimes a really sick hard drive will cause systemic problems even when you're not booting to it, but this does not sound like one of those cases to me.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Thanks. I did run the hardware test, I guess I should have mentioned that, and it said everything was ok. I will try resetting the SMC and zapping the PRAM because I've never heard that before. It is a brand new hard drive so I hope it's not sick, but I also know it wouldnt be the first.. thanks again for your responses..

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

FaceOfBear sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 1

Tutti i Tempi: 1,387