Salta al contenuto principale

Repair guides and support for the 5th generation Honda Civic, first released in late 1991.

46 Domande Visualizza tutte

speedometer sometimes work,at times it does not

i have replaced the pulse sending unit 2 times and it works only sometimes why?

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 4
Aggiungi un commento

10 Risposte

Soluzione Prescelta

Have you tried replacing the vss sensor (vehicle speed sensor)? It is located on the top part of the transmission. If you stand over the passenger side fender looking down into the engine bay you will see the intake, under that you will see the starter connected to the transmission. If you remove the intake arm from the intake manifold, and look straight down with a flash light you will see a sensor that is located on the transmission and held down by 2 10mm socket bolts. Remove the 2 bolts and twist the unit and pull the whole unit out the transmission, unplug the actual wire harness from the sensor and reverse instructions for reesemble. If all fails then you should look into replacing your gauge cluster. Good luck

Questa risposta è stata utile?

Punteggio 8

Commenti:

I am thinking this might also be the cause of the D4 light flashing.

Am I correct?

da

My 1994 Honda Civic cluster works and is plugged in, but sometimes when I’m driving and I use my turn signal my speedometer goes to zero, my temp goes to cold and my gas goes to empty, but the lights still work... still think it’s the same thing he’s dealing with or something else?

da

Aggiungi un commento

Check the grounds for the dash panel. Also, unplug, clean and replug the various plugs leading from the dash panel to the rest of the car. If you notice any that seem sloppy (loose), have burned places, or are heavily corroded, replace them.

Questa risposta è stata utile?

Punteggio 3
Aggiungi un commento

I have this problem in a 1994 Prelude (94 and up have the EL lighted gauges). The speedo will be accurate, then BAMMO I'm going 140mph or 0mph. In my car, it appears to be heat sensitive. On a hot day with the car in the sun, the speedo goes wacky and the EL lighting and the odometer goes blank and quits working.

I replaced the VSS twice. No fix. I removed the cluster and replaced a capacitor or 2. No fix. I removed the cluster and pinched every single connector pin (take apart all green connectors 1 by 1) and still no fix.

My car has 111,020 miles on it. I got a used gauge cluster from a junkyard for $80 with 188,140 miles on it and it works fine. I had to get a different gauge. Now it works.

Questa risposta è stata utile?

Punteggio 3

Commenti:

Have a 98 prelude that does the same. Only the speedometer and odometer cut out and stop working every now and again. All other gauges work fine

da

Aggiungi un commento

Ray brown pretty much nailed it.

the only thing I would add, is if the car has a engine swap, then the people who swapped it might have damaged the sensor or installed one from another vehicle and just rigged it.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

Check for corrosion on the connector. This is more common than most people think. Use a paper clip to clean off the connection points in the connector, since you've already replaced the VSS.

Questa risposta è stata utile?

Punteggio 1

Commenti:

I did that and it is good I am thinking it's a break in the wire

da

Aggiungi un commento

I’ve been having this problem for a while after fixing my leaking distributor which probably damaged my starter. I just replaced the starter today, and it’s been firing up every time.


Before I replaced the starter, I replaced all the other components mentioned on other threads: the VSS, ignition switch wiring and even the battery.


After comparing the new starter with the original OEM starter, I found a chip near the spade connector which probably affected the connection (along with the oil that was dripping on it). This little connector probably was affecting the speedometer and inconsistent starting.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

I replaced the vss but the speedo still doesn't work

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I have a similar problem with my 95 gen 4. It will work, but seems "held back". Then sometimes it will just jump up to actual speed! Seems that putting in a stereo with navigation & just use that speedo, would be cheaper.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I have a 1992 Honda Accord wagon, LX, I think.

I have been having intermittent problems such as speedometer/tachometer suddenly dropping out to zero, intermittent oil pressure light flashing, intermittent D4 gear indicator flashing.

I can shut off engine, wait for a few minutes, then restart, and it usually cures it for a short time,…. usually.

It’s been getting progressively worse; first it started with intermittent oil light flashing, then weeks later the drop-out of speedometer and tach gauges, now flashing D4 gear indicator, …and then once (so far) shutting engine off to reset the symptoms then trying to restart only to have engine not fire back up and start, taking 2 or 3 tries to get it started back up (it have never had a problem starting before, hot or cold start.)

*NOTE: I do have an oil leak, which may account for the oil light flashing, but it also seems to coincide with the other issues at this point, and generally goes out after stopping and restarting the engine.

If anyone has a GOOD sense or experience as to what is happening, I would love to hear your ideas.

(Please, no short coffee break/arm chair speculations. Looking for some good leads on the problem.)

Thanks.

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

I have a 1996 Honda Accord my speedometer works just fine but my odemeter only works every now and then and my turn signals have been failing as well can someone help?

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

coronadog sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 4

Ultimi 7 Giorni: 25

Ultimi 30 Giorni: 130

Tutti i Tempi: 48,835