Salta al contenuto principale

CDMA version of the fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. 16 or 32 GB / Model A1349 / CDMA compatibility.

294 Domande Visualizza tutte

Why is my camera(s) not working after new LCD install

I just recently replaced the broken screen and home button.

Everything seems to be working well with exception of the camera. All I get is a black screen. Seems to be loading the camera and thinks it's on but not.

Rispondi a questa domanda Anch'io ho questo problema

Questa è una buona domanda?

Punteggio -1
Aggiungi un commento

2 Risposte

seems as if the camera is not plugged in all the way...open up and check the camera flex to see if it is plugged in.

Questa risposta è stata utile?

Punteggio 0

Commenti:

I did reseat the connection to make sure. I feel now one of(all) the connections may need a cleaning. Not that it was dirty in side like my old 3gs. Which I found wood chips in:-)

da

Aggiungi un commento

It is very common to accidentally remove a small resistor that is required for rear camera function when prying the connectors off during screen replacement. You will quickly find the info that will show you how to jump the resistor for GSM iphone 4, but for CDMA it is more difficult to find. The fix is not mine to give away, but you can find it via WitesOmTesla on GSM forum.

Also, reset all settings after you first try reseating your connectors--once the camera app hangs it must be reset to function.

Jessa

Questa risposta è stata utile?

Punteggio 0

Commenti:

Thanks Jessa, I did see some info on the resistor topic. Interesting enough, my situation displays a black screen via the camera facing back, the one on the logo side. Not a closed shutter image like I've seen. The front facing or one on the screen side worked a little. It came on after a few pokes. Then couldn't get it back up. Also the HDR, flash controls are not working.

I've looked at most of the board with a high power magnifying glass and haven't found anything "broken". It is a CDMA, so I might be missing it. I'm hoping now it's just a dirty connection. I'm going to repeat my steps with of the screen and home button replacement to see if I can find out anything more.

da

Aggiungi un commento

Aggiungi la tua risposta

Michael Twing sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 0

Tutti i Tempi: 120