Salta al contenuto principale

(While Driving) Sluggish, Lost Power, Transmission?

I own a Chevrolet Tahoe 1999, 4x4 5.7L engine truck. She is my baby, I have already replaced a few things on her, i.e. radiator, O2 sensor, starter, positive terminal from battery to starter. I bought it from New Hampshire (I live in MA), the title has one owner, bought in 1999. 156,650 miles on it currently. When I drive, I feel something weird from the engine, once I accelerate, it kind of drops in power/speed. Hard to explain, but also when accelerating it just feels sluggish, it just doesnt feel right. I checked the tranny fluid, color checks out, the smell I'm not too sure of, but I was wondering if anyone could possibly give me a few tips or suggestions, I've searched high and low on the web for possibilities but nothing really hits the nail on the head. THANKS!

Risposto! Visualizza la risposta Anch'io ho questo problema

Questa è una buona domanda?

Punteggio 1
1 Commento

Are there any current or pending dtc's? Check engine light on? If so, what are the codes? There are just too many possibilities. Need more info.

Kevin

da

Aggiungi un commento

2 Risposte

Soluzione Prescelta

Quite possibly in need of a new fuel pump.

I had exactly the same symptoms on mine and the new fuel pump fixed it.

Could also be the injectors if your car smells of petrol.

Check the fuel pressure at idle and under acceleration, should be 52PSI and 68PSI or thereabout respectively.

Questa risposta è stata utile?

Punteggio 1
Aggiungi un commento

This video should help you out.

YouTube - CLEAN THROTTLE BODY

Questa risposta è stata utile?

Punteggio 0
Aggiungi un commento

Aggiungi la tua risposta

Jasmine sarà eternamente grato.
Visualizza Statistiche:

Ultime 24 Ore: 0

Ultimi 7 Giorni: 0

Ultimi 30 Giorni: 29

Tutti i Tempi: 15,507