Salta al contenuto principale

Aggiusta la tua roba

Diritto alla Riparazione

Store

Aiuto

Versione corrente di: Sam ,

Titolo:

Will boot butBoots, wont charge, stays stuck at 100% after battery flat flex repair.repair
Will boot butBoots, wont charge, stays stuck at 100% after battery flat flex repair.repair

Testo:

I have a iPhone 4 on which I managed to rip the battery flat flex cable. I removed the flat flex and connector altogether and soldered wires directly from the battery protection board to the logic board (I’m planning to get a new phone anyway and I was too lazy to do it properly and use the old connector). I tested it and it worked perfectly, I then proceeded to electrical tape it up and put it back in the phone. This is most likely where the problem occurred, I must have shorted something when putting the battery back in. The phone shows no signs of life until I plug it in, then it shows the flat but charging symbol for about 10 seconds and then proceeds to boot. The phone boots up all the way and shows between 94 and 100% on the battery indicator (the value is seemingly random every time I boot it up) but dies immediately when unplugged. If leave it plugged in it will occasionally reboot. I believe the problem is most likely the battery protection board, the cell measures 3.5 volts which is normal but the battery protection circuit is only outputting 1.2 volts to the phone. The circuit must be working to the extent that the phone can detect that there is a battery attached otherwise the phone would not boot. I am not 100% sure if this is a problem with the battery protection board or not, the low voltage may simply be due to it going into protection mode cuz the battery is almost flat. I was wondering if someone more experienced with iPhone battery issues than me could provide suggestions.

Thx

Dispositivo:

iPhone 4

Stato:

open

Post originale di: Sam ,

Titolo:

Will boot but stays stuck at 100% after battery flat flex repair.

Testo:

I have a iPhone 4 on which I managed to rip the battery flat flex cable. I removed the flat flex and connector altogether and soldered wires directly from the battery protection board to the logic board (I’m planning to get a new phone anyway and I was too lazy to do it properly and use the old connector). I tested it and it worked perfectly, I then proceeded to electrical tape it up and put it back in the phone. This is most likely where the problem occurred, I must have shorted something when putting the battery back in. The phone shows no signs of life until I plug it in, then it shows the flat but charging symbol for about 10 seconds and then proceeds to boot. The phone boots up all the way and shows between 94 and 100% on the battery indicator (the value is seemingly random every time I boot it up) but dies immediately when unplugged. If leave it plugged in it will occasionally reboot. I believe the problem is most likely the battery protection board, the cell measures 3.5 volts which is normal but the battery protection circuit is only outputting 1.2 volts to the phone. The circuit must be working to the extent that the phone can detect that there is a battery attached otherwise the phone would not boot. I am not 100% sure if this is a problem with the battery protection board or not, the low voltage may simply be due to it going into protection mode cuz the battery is almost flat. I was wondering if someone more experienced with iPhone battery issues than me could provide suggestions.

Thx

Dispositivo:

iPhone 4

Stato:

open