Salta al contenuto principale
Aiuto

Versione corrente di: oldturkey03 ,

Titolo:

acceleration problem when passing 2k rpm

Testo:

greetings!!!

I own a jeep cherokee sport 1999 4.0 4x4 standard gear with 157k miles.  Once i was driving down a hill, when suddenly i noticed that the motor was not compressing, instead it began to gain more acceleration, so i had to finish going down in neutral.  when i checked the engine compartment, i noticed that the racing tipe air filter (sorry, i don´t know the name, hope you can understand) that it had instead of the normal air filter, fell off.  I put it back on its place, but it is still giving me the problem ever since.

I have already replaced the gas pump, gas filter, cranckshaft position sensor, TPS, IAC valve, ignition coil, and spark plugs.

Now it runs a bit better, but every time i turn on the engine goes directly up to 2k rpm and goes down slowly, if i pass over 2k rpm to shift gear always goes down slowly, and sometimes, when im drivin down a hill, the motor accelerates by itself up to 3k rpm and it won´t slow down, i have to stop and turn it off.

Does somebody thinks the camshaft position sensor could give me this problem?

Has someone already had this problem and fixed it? I would so much apreciate your comments!!!       Bless you all

Dispositivo:

jeep cherokee sport 1999 4.0Jeep Cherokee
jeep cherokee sport 1999 4.0Jeep Cherokee

Stato:

open

Post originale di: Ronald ,

Titolo:

acceleration problem when passing 2k rpm

Testo:

greetings!!!

I own a jeep cherokee sport 1999 4.0 4x4 standard gear with 157k miles.  Once i was driving down a hill, when suddenly i noticed that the motor was not compressing, instead it began to gain more acceleration, so i had to finish going down in neutral.  when i checked the engine compartment, i noticed that the racing tipe air filter (sorry, i don´t know the name, hope you can understand) that it had instead of the normal air filter, fell off.  I put it back on its place, but it is still giving me the problem ever since.

I have already replaced the gas pump, gas filter, cranckshaft position sensor, TPS, IAC valve, ignition coil, and spark plugs.

Now it runs a bit better, but every time i turn on the engine goes directly up to 2k rpm and goes down slowly, if i pass over 2k rpm to shift gear always goes down slowly, and sometimes, when im drivin down a hill, the motor accelerates by itself up to 3k rpm and it won´t slow down, i have to stop and turn it off.

Does somebody thinks the camshaft position sensor could give me this problem?

Has someone already had this problem and fixed it? I would so much apreciate your comments!!!       Bless you all

Dispositivo:

jeep cherokee sport 1999 4.0

Stato:

open