Salta al contenuto principale
Aiuto

Versione corrente di: originalmachead ,

Titolo:

Runs from Battery but not charger

Testo:

I've been given a dead Mid 2010 13" Macbook Pro because it was aparantly completely dead.  When I connect the charger, the led glows very faintly green but it won't turn on.

I put a charged battery from my working macbook in it, and it turned on and worked fine - except it wouldn't detect the magsafe charger.

I then swapped the DC-in board with my working macbook but the problem remains.

So I've tried two chargers, two batteries and two DC-in boards all with the same symptoms - it works fine on the battery but not from the charger.  I guess there's a fault on the logic board somewhere...

Can anyone suggest any common faults or where to start looking on the logic board for issues?

Thanks.

Dispositivo:

MacBook Pro 13" Unibody Mid 2010

Stato:

open

Post originale di: Mike Wynne ,

Titolo:

Runs from Battery but not charger

Testo:

I've been given a dead Mid 2010 13" Macbook Pro because it was aparantly completely dead.  When I connect the charger, the led glows very faintly green but it won't turn on.

I put a charged battery from my working macbook in it, and it turned on and worked fine - except it wouldn't detect the magsafe charger.

I then swapped the DC-in board with my working macbook but the problem remains.

So I've tried two chargers, two batteries and two DC-in boards all with the same symptoms - it works fine on the battery but not from the charger.  I guess there's a fault on the logic board somewhere...

Can anyone suggest any common faults or where to start looking on the logic board for issues?

Thanks.

Dispositivo:

MacBook Pro 13" Unibody Mid 2010

Stato:

open