Salta al contenuto principale
Aiuto

Versione corrente di: Alex ,

Titolo:

Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]
-'''UPDATE 1''':
+'''UPDATE 1''':
I did the continuty test with the multimeter set to Ohm's and it beeped and gave me an oscilating result between 00.2 and 00.4 (originaly is at 1 and quickly goes down).
So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.
== '''UPDATE 2''' ==
I unscrewed my monitor completely from the macbook pro and played a little moving the LVDS cable. I left all disconnected but I plugged the LVDS cable and power on the computer...I got light! The screen working perfectly. Then power it off and re-assembly everything to place and again no backlight... but this shows that the backlight itself it's ok. So I guess the problem would be in the LVDS cable? My theory is that when I set it loose it made the connection temporarily? What do you think?

Dispositivo:

MacBook Pro 15" Unibody Mid 2012

Stato:

open

Risposta Accettata:

+363563

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]
-== '''UPDATE 1''': ==
+'''UPDATE 1''':
I did the continuty test with the multimeter set to Ohm's and it beeped and gave me an oscilating result between 00.2 and 00.4 (originaly is at 1 and quickly goes down).
-So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.
+So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.
-'''UPDATE 2'''
+== '''UPDATE 2''' ==
I unscrewed my monitor completely from the macbook pro and played a little moving the LVDS cable. I left all disconnected but I plugged the LVDS cable and power on the computer...I got light! The screen working perfectly. Then power it off and re-assembly everything to place and again no backlight... but this shows that the backlight itself it's ok. So I guess the problem would be in the LVDS cable? My theory is that when I set it loose it made the connection temporarily? What do you think?

Dispositivo:

MacBook Pro 15" Unibody Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]
-== '''UPDATE''': ==
+== '''UPDATE 1''': ==
I did the continuty test with the multimeter set to Ohm's and it beeped and gave me an oscilating result between 00.2 and 00.4 (originaly is at 1 and quickly goes down).
-So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.
+So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.
+
+'''UPDATE 2'''
+
+I unscrewed my monitor completely from the macbook pro and played a little moving the LVDS cable. I left all disconnected but I plugged the LVDS cable and power on the computer...I got light! The screen working perfectly. Then power it off and re-assembly everything to place and again no backlight... but this shows that the backlight itself it's ok. So I guess the problem would be in the LVDS cable? My theory is that when I set it loose it made the connection temporarily? What do you think?

Dispositivo:

MacBook Pro 15" Unibody Mid 2012

Stato:

open

Modifica di: Dan ,

Titolo:

Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
-[image|993471]
+[image|993471]
-==
-'''UPDATE''': ==
+== '''UPDATE''': ==
I did the continuty test with the multimeter set to Ohm's and it beeped and gave me an oscilating result between 00.2 and 00.4 (originaly is at 1 and quickly goes down).
So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.

Dispositivo:

-MacBook Pro 15" Mid 2012
+MacBook Pro 15" Unibody Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
-[image|993471]
+[image|993471]
+
+==
+'''UPDATE''': ==
+
+I did the continuty test with the multimeter set to Ohm's and it beeped and gave me an oscilating result between 00.2 and 00.4 (originaly is at 1 and quickly goes down).
+
+So, continuity seems OK for the OHM test. This leaves me in an even more intriguing scenario. Maybe the flex cable? Anything else I can test with the multimeter? I have my friend right here with me who is lending it to me for the tests.

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

-Screen Issue: No backlight (except for flashlight). Fuse? WLed?
+Screen Issue: No backlight (flashlight reveals content). Fuse? WLed?

Testo:

- Integrated monitor does not light up

- If I point a flashlight I can see apple logo on startup and log-in succesfully

- HDMI to external monitor works perfect

- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.

- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.

- Right now the internal screen haven't been on for a while (I'm using external).

- Already did all the special resets (SPM, VRAM, etc.)

- Connectors seem fine: http://imgur.com/a/rU8OL (?)

- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)

- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.

@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!

[image|993472]

[image|993471]

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (except for flashlight). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
-- Since that "incident" it stopped working gradually, sometimes would come on, sometimes not. It came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
+- Since that "incident" it stopped working gradually, sometimes integrated screen would come on, sometimes not. Once it came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
-- Right now the internal monitor haven't been on for a while (I'm using external).
+- Right now the internal screen haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (except for flashlight). Fuse? WLed?

Testo:

- Integrated monitor does not light up
- If I point a flashlight I can see apple logo on startup and log-in succesfully
- HDMI to external monitor works perfect
-- It stopped working after the HDMI broke and the TV did something strange. I think some kind of discharge. Don't know if it's coincidence though.
+- It stopped working after the third party HDMI cable broke when the TV did something strange. I guess some kind of discharge. Don't know if it's coincidence though.
- Since that "incident" it stopped working gradually, sometimes would come on, sometimes not. It came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
- Right now the internal monitor haven't been on for a while (I'm using external).
- Already did all the special resets (SPM, VRAM, etc.)
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (except for flashlight). Fuse? WLed?

Testo:

- Integrated monitor does not light up

- If I point a flashlight I can see apple logo on startup and log-in succesfully

- HDMI to external monitor works perfect

- It stopped working after the HDMI broke and the TV did something strange. I think some kind of discharge. Don't know if it's coincidence though.

- Since that "incident" it stopped working gradually, sometimes would come on, sometimes not. It came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.

- Right now the internal monitor haven't been on for a while (I'm using external).

- Already did all the special resets (SPM, VRAM, etc.)

- Connectors seem fine: http://imgur.com/a/rU8OL (?)

- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)

- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.

@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!

[image|993472]

[image|993471]

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Risposta Accettata:

-361787

Modifica di: Alex ,

Titolo:

Screen Issue: No backlight (except for flashlight). Fuse? WLed?

Testo:

- Integrated monitor does not light up
+
- If I point a flashlight I can see apple logo on startup and log-in succesfully
+
- HDMI to external monitor works perfect
+
- It stopped working after the HDMI broke and the TV did something strange. I think some kind of discharge. Don't know if it's coincidence though.
+
- Since that "incident" it stopped working gradually, sometimes would come on, sometimes not. It came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
-- Right now the internal monitor haven't been on for a while (I'm using external).
+
+- Right now the internal monitor haven't been on for a while (I'm using external).
+
- Already did all the special resets (SPM, VRAM, etc.)
+
- Connectors seem fine: http://imgur.com/a/rU8OL (?)
+
- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
[image|993472]
[image|993471]

Dispositivo:

MacBook Pro 15" Mid 2012

Stato:

open

Risposta Accettata:

+361787

Modifica di: Alex ,

Titolo:

-No backlight where is the fuse
+Screen Issue: No backlight (except for flashlight). Fuse? WLed?

Testo:

-@oldturkey03 the number is 820-3330-B (edited) . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
-[image|993472][image|993471]
+- Integrated monitor does not light up
+- If I point a flashlight I can see apple logo on startup and log-in succesfully
+- HDMI to external monitor works perfect
+- It stopped working after the HDMI broke and the TV did something strange. I think some kind of discharge. Don't know if it's coincidence though.
+- Since that "incident" it stopped working gradually, sometimes would come on, sometimes not. It came alive while tapping gently the black strip at the back of the macbook, but when I closed it and opened it back again, never came on again.
+- Right now the internal monitor haven't been on for a while (I'm using external).
+- Already did all the special resets (SPM, VRAM, etc.)
+- Connectors seem fine: http://imgur.com/a/rU8OL (?)
+- This is my logic board: http://imgur.com/a/kVLkY (820-3330-B)
+
+- I'm expecting to understand where's the problem. Identify the FUSE and how to check it, identify the WLED and how to check it. Maybe check the LVDS cable if I'm lucky that's the problem. Have no experience in chipset repair so at least I would like to identify the problem so as not to get ripped off by the technician here in Argentina.
+
+@oldturkey03 the number is 820-3330-B . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
+
+[image|993472]
+
+[image|993471]

Dispositivo:

-MacBook Pro 15" Unibody Mid 2010
+MacBook Pro 15" Mid 2012

Stato:

open

Modifica di: oldturkey03 ,

Titolo:

No backlight where is the fuse

Testo:

-@oldturkey03 the number is 820-3330-B (edited) . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
+@oldturkey03 the number is 820-3330-B (edited) . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
+[image|993472][image|993471]

Dispositivo:

MacBook Pro 15" Unibody Mid 2010

Stato:

open

Modifica di: Alex ,

Titolo:

No backlight where is the fuse

Testo:

-@oldturkey03 the number is APPLE (C) 2009 820-2565-A . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!
+@oldturkey03 the number is 820-3330-B (edited) . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!

Dispositivo:

MacBook Pro 15" Unibody Mid 2010

Stato:

open

Modifica di: oldturkey03 ,

Titolo:

-No Title (You should edit this question)
+No backlight where is the fuse

Testo:

@oldturkey03 the number is APPLE (C) 2009  820-2565-A . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!

Dispositivo:

MacBook Pro 15" Unibody Mid 2010

Stato:

open

Post originale di: Alex ,

Titolo:

No Title (You should edit this question)

Testo:

@oldturkey03 the number is APPLE (C) 2009  820-2565-A . Is this any help? And please would be nice to know how do I "check" it... I mean, what to do to realise if it's dead or working... Thanx!

Dispositivo:

MacBook Pro 15" Unibody Mid 2010

Stato:

open