Salta al contenuto principale

Aggiusta la tua roba

Diritto alla Riparazione

Store

Aiuto

Versione corrente di: oldturkey03 (dettagli voto) ,

Titolo:

mid '07 MBP 15" Dead Battery No-Mag Dead 2 the world?

Testo:

Bought this a1226 with a damaged screen for a 'project' about 4yrs ago. Due to other unrelated happenings in life, it sat in pieces, in a box, until a few months ago. Found a deal on used screen at powerbookmedic, and with a few hints/help from ifixit and PBMedic, got it put back together with no major hang-ups etc. I didn't have the magsafe ps for it, but figured I could use the magsafe from the 17" MBP that is my main comp. They're just about the same age. Plugged magsafe into 15" MBP and....Nothing. No magsafe light activity at all. Press power. Nothing. No lights, or noises. I knew the battery would need a serious charge and left  magsafe to charge overnite unmolested. Don't have external batt charger. Tried all the work-arounds/tricks I found here and youtube with no luck at all. If I plug magsafe into 17, green lite turns right on. 15 gets nothing. I didn't mess with logic board much at all. But after no signs of life 1st time, I took it apart again, to see if I'd left something major unconnected. Looked fine. So, replaced thermal grease, reassembled, and still, no signs of life.

Would it do any good, do you think, If I got the battery out of the laptop, on an external charger to try to get a good charge on it. Then try the tricks mentioned earlier to get these bricks to boot?

If anyone has any advise,  I'd love to hear it!

Dispositivo:

MacBook Pro 15" Core 2 Duo Models A1226 and A1260

Stato:

open

Risposta Accettata:

181787

Modifica di: Walter Galan ,

Titolo:

mid '07 MBP 15" Dead Battery No-Mag Dead 2 the world?

Testo:

Bought this a1226 with a damaged screen for a 'project' about 4yrs ago. Due to other unrelated happenings in life, it sat in pieces, in a box, until a few months ago. Found a deal on used screen at powerbookmedic, and with a few hints/help from ifixit and PBMedic, got it put back together with no major hang-ups etc. I didn't have the magsafe ps for it, but figured I could use the magsafe from the 17" MBP that is my main comp. They're just about the same age. Plugged magsafe into 15" MBP and....Nothing. No magsafe light activity at all. Press power. Nothing. No lights, or noises. I knew the battery would need a serious charge and left  magsafe to charge overnite unmolested. Don't have external batt charger. Tried all the work-arounds/tricks I found here and youtube with no luck at all. If I plug magsafe into 17, green lite turns right on. 15 gets nothing. I didn't mess with logic board much at all. But after no signs of life 1st time, I took it apart again, to see if I'd left something major unconnected. Looked fine. So, replaced thermal grease, reassembled, and still, no signs of life.

Would it do any good, do you think, If I got the battery out of the laptop, on an external charger to try to get a good charge on it. Then try the tricks mentioned earlier to get these bricks to boot?

If anyone has any advise,  I'd love to hear it!

Dispositivo:

mid '07 MacBookMacBook Pro 15" Core 2 Duo Models A1226 and A1260
mid '07 MacBookMacBook Pro 15" Core 2 Duo Models A1226 and A1260

Stato:

open

Post originale di: Mike McIntosh ,

Titolo:

mid '07 MBP 15" Dead Battery No-Mag Dead 2 the world?

Testo:

Bought this a1226 with a damaged screen for a 'project' about 4yrs ago. Due to other unrelated happenings in life, it sat in pieces, in a box, until a few months ago. Found a deal on used screen at powerbookmedic, and with a few hints/help from ifixit and PBMedic, got it put back together with no major hang-ups etc. I didn't have the magsafe ps for it, but figured I could use the magsafe from the 17" MBP that is my main comp. They're just about the same age. Plugged magsafe into 15" MBP and....Nothing. No magsafe light activity at all. Press power. Nothing. No lights, or noises. I knew the battery would need a serious charge and left  magsafe to charge overnite unmolested. Don't have external batt charger. Tried all the work-arounds/tricks I found here and youtube with no luck at all. If I plug magsafe into 17, green lite turns right on. 15 gets nothing. I didn't mess with logic board much at all. But after no signs of life 1st time, I took it apart again, to see if I'd left something major unconnected. Looked fine. So, replaced thermal grease, reassembled, and still, no signs of life.

Would it do any good, do you think, If I got the battery out of the laptop, on an external charger to try to get a good charge on it. Then try the tricks mentioned earlier to get these bricks to boot?

If anyone has any advise,  I'd love to hear it!

Dispositivo:

mid '07 MacBook Pro 15"

Stato:

open