Salta al contenuto principale

Aggiusta la tua roba

Diritto alla Riparazione

Store

Aiuto

Versione corrente di: David Hodson ,

Titolo:

Battery replaced, no earpiece sound

Testo:

Didn't find an answer, so...

I replaced the battery according to instructions here. But when I got to removing ribbon cable 3 with white clip, the clip started coming apart anywhere i GENTLY lifted it (as instructed of course). Was as it the plastic was old an rotten. But the cable slipped out and I actually slipped it back in on reassembly.

But alas, no sound from the little speak at the top of the screen. Is there a possibility the ribbon cable does not correctly connect even though it appears to be slipped into place?

I can hear it if I put on bluetooth, turn on the speaker, or use an earphone in the jack.

Also did not see the screen adapt to the surrounding light but I was not really testing that.

And is there a way to fix that little white clip so it works properly?

Dispositivo:

iPhone 3GS Troubleshooting
iPhone 3GS Troubleshooting

Stato:

open

Post originale di: scottroy ,

Titolo:

Battery replaced, no earpiece sound

Testo:

Didn't find an answer, so...

I replaced the battery according to instructions here. But when I got to removing ribbon cable 3 with white clip, the clip started coming apart anywhere i GENTLY lifted it (as instructed of course). Was as it the plastic was old an rotten. But the cable slipped out and I actually slipped it back in on reassembly.

But alas, no sound from the little speak at the top of the screen. Is there a possibility the ribbon cable does not correctly connect even though it appears to be slipped into place?

I can hear it if I put on bluetooth, turn on the speaker, or use an earphone in the jack.

Also did not see the screen adapt to the surrounding light but I was not really testing that.

And is there a way to fix that little white clip so it works properly?

Dispositivo:

iPhone 3GS Troubleshooting

Stato:

open